   <!DOCTYPE html>
        <html lang="en">
        <head>
<base href="http://www.galvnews.com/content/tncms/live/" />
<meta name="keywords" content="free" />
<meta name="news_keywords" content="free" />
<meta name="description" content="While the Los Angeles Galaxy had the match&rsquo;s leading man, it was the Houston Dynamo&rsquo;s supporting cast that got the win, 3-2, on Saturday night at BBVA Compass Stadium." />
<meta name="author" content="JAMES LACOMBE The Daily News" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1, user-scalable=0, shrink-to-fit=no" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://www.galvnews.com/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/b/f6/bf6be6ea-1be6-5bca-aeb5-38803fb8362c/5aee75d018b51.image.jpg?resize=825%2C630" />
<meta property="og:image:width" content="825" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Galaxy&rsquo;s star power not enough, as Dynamo win wild one" />
<meta property="og:description" content="While the Los Angeles Galaxy had the match&rsquo;s leading man, it was the Houston Dynamo&rsquo;s supporting cast that got the win, 3-2, on Saturday night at BBVA Compass Stadium." />
<meta property="og:site_name" content="The Daily News" />
<meta property="og:section" content="Free Sports" />
<meta property="fb:app_id" content="463129903709178" />
<meta property="article:publisher" content="https://www.facebook.com/GalvNews" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@GalvNews" />
<meta name="twitter:image:alt" content="Dynamo vs. Galaxy" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.2be7ddf414805ae1a81e8d6a3f9bbd90.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.da3ceb032faffbf7fd6be9a5c2d0d0ab.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.cd0988835739b53ba8cbfb67c15fc34a.css"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/live/global/resources/styles/site.css?_dc=1469211506"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=PT+Serif:400,600,700"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Playfair+Display:400,600,700"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans:400,700,600,300,300italic,400italic,600italic"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/styles/owl.carousel.d631cca58a0d014854c4a6c1815f1da3.css"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.1f0483c4aff5f459e9ce8c51222dacaf.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"page":{"app":"editorial","skin":"flex-editorial","theme":"flex","http_status":200},"client":{"is_bot":"no","noscript":false},"system":{"render_time":479}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.b354cc9d56a1da6b0c77604d1b153850.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.0d8719807a3fe7b72ef1938c41d415c2.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.aecb24225decfdb548cb8abcad610e26.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.2649d2af972a99325ee59c628f20e088.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.5b78b97d58352ac7229942b5a440124e.js"></script>
<script>/*<![CDATA[*/ (function(d,s){
        if(window.fetch&&window.Promise&&[].includes&&Object.assign&&window.Map)return;
        var sc=d.getElementsByTagName(s)[0],js=d.createElement(s);
        js.src='https://cdn.polyfill.io/v2/polyfill.min.js?features=default,fetch';
        sc.parentNode.insertBefore(js, sc);
    }(document,'script')) /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.0297325b4ae4b6f9e78641764a0f2fbe.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/ads/impressions.js?_dc=1525586738"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/ads/traffic.js?_dc=1525584921"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/ads/settings.js?_dc=1524848996"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.5fc585c500549148870d95083bafab5b.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/metering/resources/scripts/tnt.metering.6f4c373e5a9d74496cc9104c65e312dd.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.advertisements.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>

            
            <title>Galaxy’s star power not enough, as Dynamo win wild one | Free Sports | The Daily News</title>
            
    <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="http://www.galvnews.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/custom/image/e92f0070-1cda-11e7-950a-2bcf2453cc19.png?_dc=1491711219" />
    <link rel="alternate" type="application/rss+xml" title="Galaxy’s star power not enough, as Dynamo win wild one | Free Sports | The Daily News" href="http://www.galvnews.com/search/?f=rss&amp;t=article&amp;c=sports/free&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="http://www.galvnews.com/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html" />
            
        <script defer src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.358e73eee6f2b29b4d859583446a283f.js"></script>
    
            <script>
$(function(){
  
  $("#topbar-col-one-nav_menu li a").append(' <i class="fa fa-angle-double-right" aria-hidden="true"></i>');
});

</script>
        </head>
        <body class="fixed-scroll-nav  blox-asset app-editorial uuid-69b920e1-b858-59ca-a526-e462074bc51e  section-sports section-free type-article infinity-disabled tnt-svg-active">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.galvnews.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.page.app=editorial&tncms.page.skin=flex-editorial&tncms.page.theme=flex&tncms.page.http_status=200&tncms.client.is_bot=no&tncms.client.noscript=yes&tncms.system.render_time=479" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container">
            <div id="asset-edit-container-69b920e1-b858-59ca-a526-e462074bc51e" class="asset-owner-content asset-edit-container progress hidden-print">
            <div class="progress-bar progress-bar-primary progress-bar-striped">
                <div class="asset-edit-icon pull-left hidden-sm hidden-xs"><i class="fas tnt-certificate"></i></div>
                <div class="asset-edit-message pull-left">You are the owner of this article.</div>
                <div class="asset-edit-btns pull-right">
                    <a class="btn btn-primary" href="https://www.galvnews.com/users/admin/contribute/article/?assetid=69b920e1-b858-59ca-a526-e462074bc51e&assettype=article"><i class="fas tnt-pen-square"></i> Edit Article</a>
                    
                        <a class="btn btn-danger" href="https://www.galvnews.com/users/admin/contribute/article/?from_section=/sports/free"><i class="fas tnt-plus-square"></i> Add New Article</a>
                    
                </div>
                <div class="clearfix"></div>
            </div>
        </div><script>
        var oAuthors = [];jQuery(document).ready(function($){
            if( __tnt.user.loggedIn && jQuery.inArray(__tnt.user.screenName, oAuthors) !==-1 ){
                __tnt.isAuthor = true;
                $('.asset-owner-content').show();
            }
        });
    </script>
    
    

    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left  visible-sm visible-xs">
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-508975" class="tncms-block hidden-md hidden-lg"><section id="block-508975" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-508975" class="search-form-container card clearfix text-center ">
    <form id="site-search-508975" action="/search/" method="GET" >
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal form-control">
        <input id="site-search-508975-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-508975-btn" class="btn btn-link" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-508975-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-508975').submit();
        return false;
    });

    $('#site-search-508975').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-508975 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-508975 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-508975-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script></div><div id="tncms-block-508979" class="tncms-block hidden-md hidden-lg"><div id="user-controls-508979" class="user-controls show-onload clearfix default"><div class="large-user-avatar pull-left">
            <div class="tn-user-avatar pull-left"><!-- user avatar --></div>
        </div>
        <div class="large-user-controls pull-left">
            <div class="user-welcome">Welcome, <span class="tn-user-screenname">Guest</span></div><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.galvnews.com/users/signup/?referer_url=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Farticle_69b920e1-b858-59ca-a526-e462074bc51e.html" class=" user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.galvnews.com/users/login/?referer_url=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Farticle_69b920e1-b858-59ca-a526-e462074bc51e.html" class=" user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.galvnews.com/users/admin/">Dashboard</a></li>
                    <li><a class="logout-btn" onclick="jQuery('#user-logout-form-508979').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <a class="dropdown-toggle  user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><span class="user-control-link">My Account</span>
                    <b class="caret user-control-link"></b>
                </a>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li><a href="https://www.galvnews.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li><a class="tn-user-profile-url" href="" data-app="https://www.galvnews.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li><a href="https://www.galvnews.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="presentation" class="divider"></li>
                    <li><a class="logout-btn" onclick="jQuery('#user-logout-form-508979').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

    </div>

<form method="post" action="https://www.galvnews.com/users/logout/" id="user-logout-form-508979"><input type="hidden" name="referer_url" value="http://www.galvnews.com/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/" >
                                The Daily News
                            </a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-2" data-target="#mobile-nav-left_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/news/" >
                                News
                            </a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/news/" >
                                        Local News
                                    </a>
                                </li><li>
                                    <a href="/news/police/" >
                                        Police News
                                    </a>
                                </li><li>
                                    <a href="/obituaries/" >
                                        Obituaries
                                    </a>
                                </li><li>
                                    <a href="/blogs/weather_watch/" >
                                        Weather Watch Blog
                                    </a>
                                </li><li>
                                    <a href="/blogs/in_focus/" >
                                        In Focus Photo Blog
                                    </a>
                                </li><li>
                                    <a href="/news/specialreports/" >
                                        Special Reports
                                    </a>
                                </li><li>
                                    <a href="/applause/" >
                                        Applause
                                    </a>
                                </li><li>
                                    <a href="/search/" >
                                        Search
                                    </a>
                                </li><li>
                                    <a href="/news_ap/" >
                                        AP
                                    </a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-3" data-target="#mobile-nav-left_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/sports/" >
                                Sports
                            </a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/sports/" >
                                        Local Sports
                                    </a>
                                </li><li>
                                    <a href="/sports/high_school" >
                                        High School Sports
                                    </a>
                                </li><li>
                                    <a href="/sports/fishing_report/" >
                                        Reel Report
                                    </a>
                                </li><li>
                                    <a href="/site/forms/online_services/ask_sports/" >
                                        Ask the Sports Editor
                                    </a>
                                </li><li>
                                    <a href="/gametime/" >
                                        Gametime Live Scores
                                    </a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/opinion/" >
                                Opinion
                            </a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/opinion/editorials/" >
                                        Editorials
                                    </a>
                                </li><li>
                                    <a href="/opinion/letters_to_editor/" >
                                        Letters to the Editor
                                    </a>
                                </li><li>
                                    <a href="/site/forms/online_services/letter/" >
                                        Write a Letter
                                    </a>
                                </li><li>
                                    <a href="/opinion/columns/" >
                                        Columns
                                    </a>
                                </li><li>
                                    <a href="/opinion/guest_columns/" >
                                        Guest Columns
                                    </a>
                                </li><li>
                                    <a href="/comments/" >
                                        Reader Comments
                                    </a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-5" data-target="#mobile-nav-left_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a  >
                                Features
                            </a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a href="/business/" >
                                        Business
                                    </a>
                                </li><li>
                                    <a href="/education/" >
                                        Education
                                    </a>
                                </li><li>
                                    <a href="/lifestyle/" >
                                        Lifestyle
                                    </a>
                                </li><li>
                                    <a href="/food/" >
                                        Food
                                    </a>
                                </li><li>
                                    <a href="/health/" >
                                        Health
                                    </a>
                                </li><li>
                                    <a href="/leisure/" >
                                        Leisure
                                    </a>
                                </li><li>
                                    <a href="/entertainment/" >
                                        Entertainment
                                    </a>
                                </li><li>
                                    <a href="/faith/" >
                                        Faith
                                    </a>
                                </li><li>
                                    <a href="/travel/" >
                                        Travel
                                    </a>
                                </li><li>
                                    <a href="/space/" >
                                        Space
                                    </a>
                                </li><li>
                                    <a href="/announcements/" >
                                        Announcements
                                    </a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-6" data-target="#mobile-nav-left_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a  >
                                Communities
                            </a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a href="/communities/bacliff/" >
                                        Bacliff
                                    </a>
                                </li><li>
                                    <a href="/communities/bayou_vista/" >
                                        Bayou Vista
                                    </a>
                                </li><li>
                                    <a href="/communities/bolivar/" >
                                        Bolivar Peninsula
                                    </a>
                                </li><li>
                                    <a href="/communities/clear_lake_shores/" >
                                        Clear Lake Shores
                                    </a>
                                </li><li>
                                    <a href="/communities/dickinson/" >
                                        Dickinson
                                    </a>
                                </li><li>
                                    <a href="/communities/friendswood/" >
                                        Friendswood
                                    </a>
                                </li><li>
                                    <a href="/communities/galveston/" >
                                        Galveston
                                    </a>
                                </li><li>
                                    <a href="/communities/hitchcock/" >
                                        Hitchcock
                                    </a>
                                </li><li>
                                    <a href="/communities/jamaica_beach/" >
                                        Jamaica Beach
                                    </a>
                                </li><li>
                                    <a href="/communities/kemah/" >
                                        Kemah
                                    </a>
                                </li><li>
                                    <a href="/communities/la_marque/" >
                                        La Marque
                                    </a>
                                </li><li>
                                    <a href="/communities/league_city/" >
                                        League City
                                    </a>
                                </li><li>
                                    <a href="/communities/santa_fe/" >
                                        Santa Fe
                                    </a>
                                </li><li>
                                    <a href="/communities/texas_city/" >
                                        Texas City
                                    </a>
                                </li><li>
                                    <a href="/communities/tiki_island/" >
                                        Tiki Island
                                    </a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-7" data-target="#mobile-nav-left_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/news_ap/" >
                                AP
                            </a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a href="/news_ap/nation/" >
                                        Nation
                                    </a>
                                </li><li>
                                    <a href="/news_ap/politics/" >
                                        Politics
                                    </a>
                                </li><li>
                                    <a href="/news_ap/business/" >
                                        Business
                                    </a>
                                </li><li>
                                    <a href="/news_ap/entertainment/" >
                                        Entertainment
                                    </a>
                                </li><li>
                                    <a href="/news_ap/sports/" >
                                        Sports
                                    </a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-8" data-target="#mobile-nav-left_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/services/" >
                                Services
                            </a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a href="/site/about.html" >
                                        About Us
                                    </a>
                                </li><li>
                                    <a href="/site/services/" >
                                        Newspaper Delivery
                                    </a>
                                </li><li>
                                    <a href="/site/forms/subscription_services/paybill/" >
                                        Make a Payment
                                    </a>
                                </li><li>
                                    <a href="/site/forms/subscription_services/giftsubscribe/" >
                                        Gift Subscriptions
                                    </a>
                                </li><li>
                                    <a href="http://galvnews.mycapture.com"  target="_blank" rel="noopener">
                                        Photo Reprints
                                    </a>
                                </li><li>
                                    <a href="/site/forms/subscription_services/vacation/" >
                                        Vacation Stops
                                    </a>
                                </li><li>
                                    <a href="/site/forms/subscription_services/back_issues/" >
                                        Order Back Issues
                                    </a>
                                </li><li>
                                    <a href="/site/newsstand_locations.html" >
                                        Newsstand Locations
                                    </a>
                                </li><li>
                                    <a href="/site/nie.html" >
                                        Newspaper in Education
                                    </a>
                                </li><li>
                                    <a href="/site/reprints.html" >
                                        Reprints
                                    </a>
                                </li><li>
                                    <a href="/site/staff_directory.html" >
                                        Staff Directory
                                    </a>
                                </li><li>
                                    <a href="/site/the_daily_news.html" >
                                        History of The Daily News
                                    </a>
                                </li><li>
                                    <a href="/site/forms/online_services/contact_support/" >
                                        Contact Support
                                    </a>
                                </li><li>
                                    <a href="/site/forms/subscription_services/carrier/" >
                                        Apply to be a Newspaper Carrier
                                    </a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-9" data-target="#mobile-nav-left_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/classifieds/" >
                                Advertising
                            </a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a href="http://findnsave.galvnews.com"  target="_blank" rel="noopener">
                                        Newspaper Ads: Find & Save
                                    </a>
                                </li><li>
                                    <a href="/classifieds/job" >
                                        Jobs
                                    </a>
                                </li><li>
                                    <a href="/classifieds/housing/sale/" >
                                        Homes for Sale
                                    </a>
                                </li><li>
                                    <a href="/classifieds/housing/rent/" >
                                        Housing: Rentals
                                    </a>
                                </li><li>
                                    <a href="/classifieds/community/" >
                                        Announcements
                                    </a>
                                </li><li>
                                    <a href="/classifieds/vehicle/" >
                                        Automotive
                                    </a>
                                </li><li>
                                    <a href="/classifieds/sale/sale/garage/" >
                                        Garage Sales
                                    </a>
                                </li><li>
                                    <a href="/classifieds/sale/" >
                                        Items for Sale
                                    </a>
                                </li><li>
                                    <a href="/classifieds/job/" >
                                        Jobs
                                    </a>
                                </li><li>
                                    <a href="/classifieds/community/announcements/" >
                                        Legals
                                    </a>
                                </li><li>
                                    <a href="/classifieds/housing/rent/" >
                                        Property for Rent
                                    </a>
                                </li><li>
                                    <a href="/classifieds/housing/sale/" >
                                        Real Estate
                                    </a>
                                </li><li>
                                    <a href="/classifieds/service/" >
                                        Services
                                    </a>
                                </li><li>
                                    <a href="/classifieds/sale/pet/" >
                                        Pets
                                    </a>
                                </li><li>
                                    <a href="/animal_lovers/" >
                                        The Daily News
                                    </a>
                                </li><li>
                                    <a href="/site/forms/online_services/classified/" >
                                        Place an Ad
                                    </a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/specialsections/" >
                                Special Sections
                            </a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/marketplace/" >
                                Marketplace
                            </a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/eedition/" >
                                e-Edition
                            </a>
                        </div>
                    </div></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6">
        <div id="tncms-region-topbar-col-one" class="tncms-region "></div>
        <div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list"><li>
                <a class="nav-link"  href="/newsletters/" >
                    <span class="nav-label">Subscribe to Email Newsletters And Breaking News Alerts</span>
                </a></li></ul></div>
    </div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6">
        <div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-508978" class="tncms-block"><div id="user-controls-508978" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.galvnews.com/users/signup/?referer_url=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Farticle_69b920e1-b858-59ca-a526-e462074bc51e.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.galvnews.com/users/login/?referer_url=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Farticle_69b920e1-b858-59ca-a526-e462074bc51e.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.galvnews.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="jQuery('#user-logout-form-508978').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li><a href="https://www.galvnews.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li><a class="tn-user-profile-url" href="" data-app="https://www.galvnews.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li><a href="https://www.galvnews.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="presentation" class="divider"></li>
                    <li><a class="logout-btn" onclick="jQuery('#user-logout-form-508978').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.galvnews.com/users/logout/" id="user-logout-form-508978"><input type="hidden" name="referer_url" value="http://www.galvnews.com/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-508976" class="tncms-block"><div class="follow-links-508976 pull-right">
    
    <section id="block-508976" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/GalvNews" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/GalvNews" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "http://schema.org",
  "@type" : "Organization",
  "url" : "http://www.galvnews.com",
  "sameAs" : ["https://www.facebook.com/GalvNews","https://twitter.com/GalvNews"] 
}
</script>
<div class="clearfix"></div>
    <script>
        jQuery(document).ready(function(){
            $('.follow-links-508976 li a').tooltip({
                placement:'bottom'
            });
        });
    </script>
</div></div>
        
    </div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12">
                        <div id="tncms-region-masthead-full-top" class="tncms-region "><div id="tncms-block-508839" class="tncms-block hidden-xs"><script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.galvnews.com",
  secureDomain: "www.galvnews.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div id="blox-ad-position-block-leaderboard-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top","slot":"1","fold":"above","width":"728","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/galvnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div>
                    </div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4">
        <div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-508980" class="tncms-block"><div id="weather-508980" class="weather-current size-medium pull-left">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=77553" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                        <span class="pull-left btn btn-xs btn-danger weather-alert-btn" data-toggle="tooltip" data-placement="right" title="Weather Alert"><i class="fas tnt-exclamation-triangle"></i></span>
                        <script>
                            jQuery(document).ready(function(){
                                $('.weather-alert-btn').tooltip();
                            });
                        </script>
                    
                    <span class="fas tnt-wi-night-clear"></span>
                </span>
                <span class="pull-left temp-desc medium">
                    <span class="temp">73&deg;</span>
                    
                        <span class="cond">Fair <i class="fas tnt-caret-down"></i></span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu" aria-labelledby="weatherExpanded">
                    <li>
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="77553"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" onclick="jQuery('#weather-508980 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Galveston, Texas
                                
                                 <small>(77553)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Mostly sunny skies. High around 85F. Winds N at 5 to 10 mph..</p>
                            <h5>Tonight</h5>
                            <p>A mostly clear sky. Low 68F. Winds WSW at 5 to 10 mph.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: May 6, 2018 @ 12:52 am</small></p>
                        </div>
                    </li>
                    <li role="presentation" class="divider"></li>
                    <li class="forecast-link text-center"><a href="/weather/?weather_zip=77553"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div>
    </div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4">
        <div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-508898" class="tncms-block a"><section id="block-508898" class="block emphasis-h3   " ><div class="block">
        <a href="/" >
            <img src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/custom/image/14ce14c0-1cd9-11e7-9307-577311c794b0.png?_dc=1491710434" class="img-responsive" alt="">
        </a>
    </div></section></div></div>
    </div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4">
        <div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-508974" class="tncms-block new-search"><section id="block-508974" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-508974" class="search-form-container card clearfix text-center ">
    <form id="site-search-508974" action="/search/" method="GET" >
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right input-group-sm form-control">
        <input id="site-search-508974-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-508974-btn" class="btn btn-link" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-508974-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-508974').submit();
        return false;
    });

    $('#site-search-508974').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-508974 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-508974 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-508974-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script></div></div>
    </div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12">
                        <div id="tncms-region-masthead-full-bottom" class="tncms-region "><div id="tncms-block-510538" class="tncms-block"><div class="dater pull-left">
<p>May 6, 2018</p>
</div></div><div id="tncms-block-510512" class="tncms-block tagline"><section id="block-510512" class="block emphasis-h3   " ><div class="block">
        <a href="/" >
            <img src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/custom/image/1aca398a-1cd9-11e7-a981-5f9a62a83fca.png?_dc=1491710444" class="img-responsive" alt="">
        </a>
    </div></section></div><div id="tncms-block-510540" class="tncms-block"><div class="subs-link pull-right"><a href="/site/services/">Subscribe Today</a></div></div></div>
                    </div>
                </div>
                
            </header>
        </div>
    

    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" visible-sm visible-xs navbar-toggle pull-left" data-toggle="offcanvas" data-target="left">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            
                        </button>
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_left">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-508971" class="tncms-block"><section id="block-508971" class="block emphasis-h3   " ><div class="block">
        <a href="/" >
            <img src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/custom/image/0b249890-1cd9-11e7-89b7-4b40c6f7ad36.png?_dc=1491710417" class="img-responsive" alt="">
        </a>
    </div></section></div></div>
                            
                        </div>
                    

                                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li>
                <a class="nav-link nav-home"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">The Daily News</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news/" >
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu"><li>
                <a class="nav-link"  href="/news/" >
                    <span class="nav-label">Local News</span>
                </a></li><li>
                <a class="nav-link"  href="/news/police/" >
                    <span class="nav-label">Police News</span>
                </a></li><li>
                <a class="nav-link"  href="/obituaries/" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link"  href="/blogs/weather_watch/" >
                    <span class="nav-label">Weather Watch Blog</span>
                </a></li><li>
                <a class="nav-link"  href="/blogs/in_focus/" >
                    <span class="nav-label">In Focus Photo Blog</span>
                </a></li><li>
                <a class="nav-link"  href="/news/specialreports/" >
                    <span class="nav-label">Special Reports</span>
                </a></li><li>
                <a class="nav-link"  href="/applause/" >
                    <span class="nav-label">Applause</span>
                </a></li><li>
                <a class="nav-link"  href="/search/" >
                    <span class="nav-label">Search</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/news_ap/" >
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">AP</span>
                </a><ul id="main-nav_menu-child-2-child-9" class="dropdown-menu"><li>
                <a class="nav-link"  href="/news_ap/texas/" >
                    <span class="nav-label">Texas</span>
                </a></li><li>
                <a class="nav-link"  href="/news_ap/nation/" >
                    <span class="nav-label">Nation</span>
                </a></li><li>
                <a class="nav-link"  href="/news_ap/world/" >
                    <span class="nav-label">World</span>
                </a></li><li>
                <a class="nav-link"  href="/news_ap/politics/" >
                    <span class="nav-label">Politics</span>
                </a></li><li>
                <a class="nav-link"  href="/news_ap/business/" >
                    <span class="nav-label">Business</span>
                </a></li><li>
                <a class="nav-link"  href="/news_ap/technology/" >
                    <span class="nav-label">Technology</span>
                </a></li><li>
                <a class="nav-link"  href="/news_ap/science/" >
                    <span class="nav-label">Science</span>
                </a></li><li>
                <a class="nav-link"  href="/news_ap/health/" >
                    <span class="nav-label">Health</span>
                </a></li><li>
                <a class="nav-link"  href="/news_ap/entertainment/" >
                    <span class="nav-label">Entertainment</span>
                </a></li><li>
                <a class="nav-link"  href="/news_ap/sports/" >
                    <span class="nav-label">Sports</span>
                </a></li></ul></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports/" >
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu"><li>
                <a class="nav-link"  href="/sports/" >
                    <span class="nav-label">Local Sports</span>
                </a></li><li>
                <a class="nav-link"  href="/sports/high_school" >
                    <span class="nav-label">High School Sports</span>
                </a></li><li>
                <a class="nav-link"  href="/sports/fishing_report/" >
                    <span class="nav-label">Reel Report</span>
                </a></li><li>
                <a class="nav-link"  href="/site/forms/online_services/ask_sports/" >
                    <span class="nav-label">Ask the Sports Editor</span>
                </a></li><li>
                <a class="nav-link"  href="/gametime/" >
                    <span class="nav-label">Gametime Live Scores</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinion/" >
                    <span class="nav-label">Opinion</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu"><li>
                <a class="nav-link"  href="/opinion/editorials/" >
                    <span class="nav-label">Editorials</span>
                </a></li><li>
                <a class="nav-link"  href="/opinion/letters_to_editor/" >
                    <span class="nav-label">Letters to the Editor</span>
                </a></li><li>
                <a class="nav-link"  href="/site/forms/online_services/letter/" >
                    <span class="nav-label">Write a Letter</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/opinion/columns/" >
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">Columns</span>
                </a><ul id="main-nav_menu-child-4-child-4" class="dropdown-menu"><li>
                <a class="nav-link"  href="/opinion/columns/leonard_woolsey/" >
                    <span class="nav-label">Leonard Woolsey</span>
                </a></li></ul></li><li>
                <a class="nav-link"  href="/opinion/guest_columns/" >
                    <span class="nav-label">Guest Columns</span>
                </a></li><li>
                <a class="nav-link"  href="/comments/" >
                    <span class="nav-label">Reader Comments</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Features</span>
                </a><ul id="main-nav_menu-child-5" class="dropdown-menu"><li>
                <a class="nav-link"  href="/business/" >
                    <span class="nav-label">Business</span>
                </a></li><li>
                <a class="nav-link"  href="/education/" >
                    <span class="nav-label">Education</span>
                </a></li><li>
                <a class="nav-link"  href="/lifestyle/" >
                    <span class="nav-label">Lifestyle</span>
                </a></li><li>
                <a class="nav-link"  href="/food/" >
                    <span class="nav-label">Food</span>
                </a></li><li>
                <a class="nav-link"  href="/health/" >
                    <span class="nav-label">Health</span>
                </a></li><li>
                <a class="nav-link"  href="/leisure/" >
                    <span class="nav-label">Leisure</span>
                </a></li><li>
                <a class="nav-link"  href="/entertainment/" >
                    <span class="nav-label">Entertainment</span>
                </a></li><li>
                <a class="nav-link"  href="/faith/" >
                    <span class="nav-label">Faith</span>
                </a></li><li>
                <a class="nav-link"  href="/travel/" >
                    <span class="nav-label">Travel</span>
                </a></li><li>
                <a class="nav-link"  href="/space/" >
                    <span class="nav-label">Space</span>
                </a></li><li>
                <a class="nav-link"  href="/announcements/" >
                    <span class="nav-label">Announcements</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Communities</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu"><li>
                <a class="nav-link"  href="/communities/bacliff/" >
                    <span class="nav-label">Bacliff</span>
                </a></li><li>
                <a class="nav-link"  href="/communities/bayou_vista/" >
                    <span class="nav-label">Bayou Vista</span>
                </a></li><li>
                <a class="nav-link"  href="/communities/bolivar/" >
                    <span class="nav-label">Bolivar Peninsula</span>
                </a></li><li>
                <a class="nav-link"  href="/communities/clear_lake_shores/" >
                    <span class="nav-label">Clear Lake Shores</span>
                </a></li><li>
                <a class="nav-link"  href="/communities/dickinson/" >
                    <span class="nav-label">Dickinson</span>
                </a></li><li>
                <a class="nav-link"  href="/communities/friendswood/" >
                    <span class="nav-label">Friendswood</span>
                </a></li><li>
                <a class="nav-link"  href="/communities/galveston/" >
                    <span class="nav-label">Galveston</span>
                </a></li><li>
                <a class="nav-link"  href="/communities/hitchcock/" >
                    <span class="nav-label">Hitchcock</span>
                </a></li><li>
                <a class="nav-link"  href="/communities/jamaica_beach/" >
                    <span class="nav-label">Jamaica Beach</span>
                </a></li><li>
                <a class="nav-link"  href="/communities/kemah/" >
                    <span class="nav-label">Kemah</span>
                </a></li><li>
                <a class="nav-link"  href="/communities/la_marque/" >
                    <span class="nav-label">La Marque</span>
                </a></li><li>
                <a class="nav-link"  href="/communities/league_city/" >
                    <span class="nav-label">League City</span>
                </a></li><li>
                <a class="nav-link"  href="/communities/santa_fe/" >
                    <span class="nav-label">Santa Fe</span>
                </a></li><li>
                <a class="nav-link"  href="/communities/texas_city/" >
                    <span class="nav-label">Texas City</span>
                </a></li><li>
                <a class="nav-link"  href="/communities/tiki_island/" >
                    <span class="nav-label">Tiki Island</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news_ap/" >
                    <span class="nav-label">AP</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu"><li>
                <a class="nav-link"  href="/news_ap/nation/" >
                    <span class="nav-label">Nation</span>
                </a></li><li>
                <a class="nav-link"  href="/news_ap/politics/" >
                    <span class="nav-label">Politics</span>
                </a></li><li>
                <a class="nav-link"  href="/news_ap/business/" >
                    <span class="nav-label">Business</span>
                </a></li><li>
                <a class="nav-link"  href="/news_ap/entertainment/" >
                    <span class="nav-label">Entertainment</span>
                </a></li><li>
                <a class="nav-link"  href="/news_ap/sports/" >
                    <span class="nav-label">Sports</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/services/" >
                    <span class="nav-label">Services</span>
                </a><ul id="main-nav_menu-child-8" class="dropdown-menu"><li>
                <a class="nav-link"  href="/site/about.html" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link"  href="/site/services/" >
                    <span class="nav-label">Newspaper Delivery</span>
                </a></li><li>
                <a class="nav-link"  href="/site/forms/subscription_services/paybill/" >
                    <span class="nav-label">Make a Payment</span>
                </a></li><li>
                <a class="nav-link"  href="/site/forms/subscription_services/giftsubscribe/" >
                    <span class="nav-label">Gift Subscriptions</span>
                </a></li><li>
                <a class="nav-link"  href="http://galvnews.mycapture.com"  target="_blank" rel="noopener">
                    <span class="nav-label">Photo Reprints</span>
                </a></li><li>
                <a class="nav-link"  href="/site/forms/subscription_services/vacation/" >
                    <span class="nav-label">Vacation Stops</span>
                </a></li><li>
                <a class="nav-link"  href="/site/forms/subscription_services/back_issues/" >
                    <span class="nav-label">Order Back Issues</span>
                </a></li><li>
                <a class="nav-link"  href="/site/newsstand_locations.html" >
                    <span class="nav-label">Newsstand Locations</span>
                </a></li><li>
                <a class="nav-link"  href="/site/nie.html" >
                    <span class="nav-label">Newspaper in Education</span>
                </a></li><li>
                <a class="nav-link"  href="/site/reprints.html" >
                    <span class="nav-label">Reprints</span>
                </a></li><li>
                <a class="nav-link"  href="/site/staff_directory.html" >
                    <span class="nav-label">Staff Directory</span>
                </a></li><li>
                <a class="nav-link"  href="/site/the_daily_news.html" >
                    <span class="nav-label">History of The Daily News</span>
                </a></li><li>
                <a class="nav-link"  href="/site/forms/online_services/contact_support/" >
                    <span class="nav-label">Contact Support</span>
                </a></li><li>
                <a class="nav-link"  href="/site/forms/subscription_services/carrier/" >
                    <span class="nav-label">Apply to be a Newspaper Carrier</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/classifieds/" >
                    <span class="nav-label">Advertising</span>
                </a><ul id="main-nav_menu-child-9" class="dropdown-menu"><li>
                <a class="nav-link"  href="http://findnsave.galvnews.com"  target="_blank" rel="noopener">
                    <span class="nav-label">Newspaper Ads: Find & Save</span>
                </a></li><li>
                <a class="nav-link"  href="/classifieds/job" >
                    <span class="nav-label">Jobs</span>
                </a></li><li>
                <a class="nav-link"  href="/classifieds/housing/sale/" >
                    <span class="nav-label">Homes for Sale</span>
                </a></li><li>
                <a class="nav-link"  href="/classifieds/housing/rent/" >
                    <span class="nav-label">Housing: Rentals</span>
                </a></li><li>
                <a class="nav-link"  href="/classifieds/community/" >
                    <span class="nav-label">Announcements</span>
                </a></li><li>
                <a class="nav-link"  href="/classifieds/vehicle/" >
                    <span class="nav-label">Automotive</span>
                </a></li><li>
                <a class="nav-link"  href="/classifieds/sale/sale/garage/" >
                    <span class="nav-label">Garage Sales</span>
                </a></li><li>
                <a class="nav-link"  href="/classifieds/sale/" >
                    <span class="nav-label">Items for Sale</span>
                </a></li><li>
                <a class="nav-link"  href="/classifieds/job/" >
                    <span class="nav-label">Jobs</span>
                </a></li><li>
                <a class="nav-link"  href="/classifieds/community/announcements/" >
                    <span class="nav-label">Legals</span>
                </a></li><li>
                <a class="nav-link"  href="/classifieds/housing/rent/" >
                    <span class="nav-label">Property for Rent</span>
                </a></li><li>
                <a class="nav-link"  href="/classifieds/housing/sale/" >
                    <span class="nav-label">Real Estate</span>
                </a></li><li>
                <a class="nav-link"  href="/classifieds/service/" >
                    <span class="nav-label">Services</span>
                </a></li><li>
                <a class="nav-link"  href="/classifieds/sale/pet/" >
                    <span class="nav-label">Pets</span>
                </a></li><li>
                <a class="nav-link"  href="/animal_lovers/" >
                    <span class="nav-label">The Daily News</span>
                </a></li><li>
                <a class="nav-link"  href="/site/forms/online_services/classified/" >
                    <span class="nav-label">Place an Ad</span>
                </a></li></ul></li><li>
                <a class="nav-link"  href="/specialsections/" >
                    <span class="nav-label">Special Sections</span>
                </a></li><li>
                <a class="nav-link"  href="/marketplace/" >
                    <span class="nav-label">Marketplace</span>
                </a></li><li>
                <a class="nav-link"  href="/eedition/" >
                    <span class="nav-label">e-Edition</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
        </div>
        
            
                <script>
                    jQuery(document).ready(function($){
                        var sNavContainer = '#site-navbar-container';
                        var sBodyContainer = '#main-body-container';
                        var sNavHeight = $(sNavContainer).height();
                        var iUnfixPoint = 0;
                        if( __tnt.client.platform.ios ){
                            $(sNavContainer).addClass('affix-sticky');
                        } else {
                            $sNavScroll = false;
                            $(window).on('scroll mousewheel', function(){
                                if( !$sNavScroll ){
                                    $sNavScroll = true;
                                    setTimeout(function(){
                                        var iFixPoint = $(sNavContainer).offset().top;
                                        var iCurrPoint = $(this).scrollTop();
                                        if( iCurrPoint >= iFixPoint && iCurrPoint > iUnfixPoint ){
                                            if( !$(sNavContainer).hasClass('affix') ){ 
                                                iUnfixPoint = iFixPoint;
                                                $(sNavContainer).addClass('affix').removeClass('affix-top');
                                                $(sBodyContainer).css('margin-top', sNavHeight+'px'); 
                                            }
                                        } else {
                                            if( !$(sNavContainer).hasClass('affix-top') ){ 
                                                $(sNavContainer).removeClass('affix').addClass('affix-top');
                                                $(sBodyContainer).css('margin-top', 0);
                                            }
                                        }
                                        $sNavScroll = false;
                                    }, 25);
                                }
                            });
                        }
                    });
                </script>
            
        
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-508840" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-leaderboard-top-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top-mobile","slot":"1","fold":"above","width":"320","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/galvnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-508965" class="tncms-block"><section id="block-508965" class="block emphasis-h3 light  " ><div class="clearfix"></div>
        <div class="breaking show-images">
            <div class="breaking-container clearfix">
                <div id="breaking-title-508965" class="breaking-title text-left light" >
                    <h4>Breaking News</h4>
                </div>
                <div id="breaking-content-508965" class="breaking-content card-img-sm card-compact card-bg-color">
                    
                        
                            <article id="card-summary-508965-27678992-b549-52f5-9b69-63ee9610a38d" class="clearfix card summary  card-section-news-free">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h2 class="tnt-headline ">
        
             <a href="/news/free/article_27678992-b549-52f5-9b69-63ee9610a38d.html">
        

        
        2018 Local Elections, Final Election Night Results</a></h2></div><div class="card-meta">
            <ul class="list-inline"><li><span class="text-muted">Updated </span><time datetime="2018-05-05T21:14:43-05:00" class="asset-date text-muted">4 hrs ago</time>
    </li><li><a href="/news/free/article_27678992-b549-52f5-9b69-63ee9610a38d.html#comments" class="cm" title="2 comments"><span class="fas tnt-comments"></span> <span class="count">2</span></a>
</li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                        
                    
                </div>
            </div>
        </div>
    </section>
    </div><div id="tncms-block-533937" class="tncms-block"></div><div id="tncms-block-532211" class="tncms-block"></div></div></div>
        </div><div class="modal fullscreen" id="photo-carousel-69b920e1-b858-59ca-a526-e462074bc51e" tabindex="-1" role="dialog" aria-labelledby="photo-carousel" aria-hidden="true">
        <div class="modal-dialog modal-lg">
            <div class="modal-content">
                <div class="modal-body">
                    <button type="button" class="close" data-dismiss="modal">
                        <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                        <span class="sr-only">Close</span>
                    </button>
                    <div id="carousel-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal" class="card photo-carousel    subscriber-hide">
            <div class="photo-carousel-control-container">
                    <span class="photo-count">
                        <span class="current-count">1</span> of 7
                    </span>
                    <a class="photo-carousel-control left noselect hidden-print"><span class="control-left fas tnt-chevron-left"></span></a>
                    <a class="photo-carousel-control right noselect hidden-print"><span class="control-left fas tnt-chevron-right"></span></a>
            </div>
            <div id="gallery-items-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal" class="carousel-inner">
                        <div class="item photo-bf6be6ea-1be6-5bca-aeb5-38803fb8362c">
                            <div class="item-container">
        
                                <div data-track-object='{"title":"Galaxy’s star power not enough, as Dynamo win wild one","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html","uuid":"69b920e1-b858-59ca-a526-e462074bc51e","app":"editorial","metric":""}'  data-count="1"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                        
                                        
        
        
        
                <img
                    src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/b/f6/bf6be6ea-1be6-5bca-aeb5-38803fb8362c/5aee75d018b51.image.jpg?resize=1200%2C917"
                    
                    alt="Dynamo vs. Galaxy"
                    class="img-responsive owl-first-image owl-lazy"
                    width="1647"
                    height="1258"
                    data-src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/b/f6/bf6be6ea-1be6-5bca-aeb5-38803fb8362c/5aee75d018b51.image.jpg?resize=1200%2C917" />
                                        
                                        
                                </div>
        <div class="caption-container">
                
                    <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal" data-target=".caption-inner-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal">
                        <i class="fas tnt-minus-circle"></i>
                    </span>
                
            <div class="caption-inner-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal collapse in"><div class="caption-text"><p>Houston Dynamo forward Alberth Elis gets kneed in the chest by L.A. Galaxy goalkeeper David Bingham during a game at BBVA Compass Stadium in Houston on Saturday, May 5, 2018. The Dynamo won the game 3-2.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span id="author-656b01ae-7620-11e7-9848-5cb9017bff18-asset-bf6be6ea-1be6-5bca-aeb5-38803fb8362c" class="asset-byline"  ><a href="https://www.galvnews.com/users/profile/Kelsey%20Walling">KELSEY WALLING/The Daily News</a></span>
                </li>
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        
    <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_bf6be6ea-1be6-5bca-aeb5-38803fb8362c.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" rel="noopener" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/free/image_bf6be6ea-1be6-5bca-aeb5-38803fb8362c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":bf6be6ea-1be6-5bca-aeb5-38803fb8362c}'  rel="nofollow">
            
                <span class=" tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_bf6be6ea-1be6-5bca-aeb5-38803fb8362c.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share&text=Dynamo%20vs.%20Galaxy&via=GalvNews" class="tw" target="_blank" rel="noopener" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/free/image_bf6be6ea-1be6-5bca-aeb5-38803fb8362c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":bf6be6ea-1be6-5bca-aeb5-38803fb8362c}'  rel="nofollow">
                <span class=" tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BThe%20Daily%20News%5D%20Dynamo%20vs.%20Galaxy&body=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_bf6be6ea-1be6-5bca-aeb5-38803fb8362c.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":bf6be6ea-1be6-5bca-aeb5-38803fb8362c}'  rel="nofollow">
                <span class=" tnt-stack" >
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/free/image_bf6be6ea-1be6-5bca-aeb5-38803fb8362c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":bf6be6ea-1be6-5bca-aeb5-38803fb8362c}'  rel="nofollow">
                    <span class=" tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link">
        <a class="save-list-bf6be6ea-1be6-5bca-aeb5-38803fb8362c-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="bf6be6ea-1be6-5bca-aeb5-38803fb8362c" >
            <span class=" tnt-stack">
                
                <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
            </span>
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul>
    <form method="post" data-uuid="bf6be6ea-1be6-5bca-aeb5-38803fb8362c" class="save-list-bf6be6ea-1be6-5bca-aeb5-38803fb8362c-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="bf6be6ea-1be6-5bca-aeb5-38803fb8362c" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
                        <div class="item photo-109bbc0c-5dfb-5a32-8e65-be768988fdc6 hidden-print">
                            <div class="item-container">
        
                                <div data-track-object='{"title":"Galaxy’s star power not enough, as Dynamo win wild one","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html","uuid":"69b920e1-b858-59ca-a526-e462074bc51e","app":"editorial","metric":""}'  data-count="2"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                        
                                        
        
        
        
                <img
                    src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/1/09/109bbc0c-5dfb-5a32-8e65-be768988fdc6/5aee75cf72891.image.jpg?resize=1200%2C924"
                    
                    alt="Dynamo vs. Galaxy"
                    class="img-responsive owl-first-image owl-lazy"
                    width="1641"
                    height="1263"
                    data-src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/1/09/109bbc0c-5dfb-5a32-8e65-be768988fdc6/5aee75cf72891.image.jpg?resize=1200%2C924" />
                                        
                                        
                                </div>
        <div class="caption-container">
                
                    <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal" data-target=".caption-inner-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal">
                        <i class="fas tnt-minus-circle"></i>
                    </span>
                
            <div class="caption-inner-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal collapse in"><div class="caption-text"><p>Dynamo midfielder Osdcar Boniek Garcia gets the ball away from L.A. Galaxy midfielder Jonathon dos Santos <span class="print_trim">during a game at BBVA Compass Stadium in Houston</span> on Saturday<span class="print_trim">, May 5, 2018</span>.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span id="author-656b01ae-7620-11e7-9848-5cb9017bff18-asset-109bbc0c-5dfb-5a32-8e65-be768988fdc6" class="asset-byline"  ><a href="https://www.galvnews.com/users/profile/Kelsey%20Walling">KELSEY WALLING/The Daily News
<!--p:PC Photo Credit--></a></span>
                </li>
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        
    <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_109bbc0c-5dfb-5a32-8e65-be768988fdc6.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" rel="noopener" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/free/image_109bbc0c-5dfb-5a32-8e65-be768988fdc6.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":109bbc0c-5dfb-5a32-8e65-be768988fdc6}'  rel="nofollow">
            
                <span class=" tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_109bbc0c-5dfb-5a32-8e65-be768988fdc6.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share&text=Dynamo%20vs.%20Galaxy&via=GalvNews" class="tw" target="_blank" rel="noopener" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/free/image_109bbc0c-5dfb-5a32-8e65-be768988fdc6.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":109bbc0c-5dfb-5a32-8e65-be768988fdc6}'  rel="nofollow">
                <span class=" tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BThe%20Daily%20News%5D%20Dynamo%20vs.%20Galaxy&body=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_109bbc0c-5dfb-5a32-8e65-be768988fdc6.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":109bbc0c-5dfb-5a32-8e65-be768988fdc6}'  rel="nofollow">
                <span class=" tnt-stack" >
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/free/image_109bbc0c-5dfb-5a32-8e65-be768988fdc6.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":109bbc0c-5dfb-5a32-8e65-be768988fdc6}'  rel="nofollow">
                    <span class=" tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link">
        <a class="save-list-109bbc0c-5dfb-5a32-8e65-be768988fdc6-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="109bbc0c-5dfb-5a32-8e65-be768988fdc6" >
            <span class=" tnt-stack">
                
                <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
            </span>
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul>
    <form method="post" data-uuid="109bbc0c-5dfb-5a32-8e65-be768988fdc6" class="save-list-109bbc0c-5dfb-5a32-8e65-be768988fdc6-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="109bbc0c-5dfb-5a32-8e65-be768988fdc6" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
                        <div class="item photo-daf3013a-2287-51ae-a0e6-b75c59307c56 hidden-print">
                            <div class="item-container">
        
                                <div data-track-object='{"title":"Galaxy’s star power not enough, as Dynamo win wild one","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html","uuid":"69b920e1-b858-59ca-a526-e462074bc51e","app":"editorial","metric":""}'  data-count="3"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                        
                                        
        
        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                    alt="Dynamo vs. Galaxy"
                    class="img-responsive owl-lazy"
                    width="1635"
                    height="1268"
                    data-src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/d/af/daf3013a-2287-51ae-a0e6-b75c59307c56/5aee75d0b940c.image.jpg?resize=1200%2C931" />
                                        
                                        
                                </div>
        <div class="caption-container">
                
                    <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal" data-target=".caption-inner-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal">
                        <i class="fas tnt-minus-circle"></i>
                    </span>
                
            <div class="caption-inner-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal collapse in"><div class="caption-text"><p>Houston Dynamo defender DaMarcus Beasley kicks for an attempted goal as L.A. Galaxy forward Chris Pontius attempts to block him during a game at BBVA Compass Stadium in Houston on Saturday, May 5, 2018.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span id="author-656b01ae-7620-11e7-9848-5cb9017bff18-asset-daf3013a-2287-51ae-a0e6-b75c59307c56" class="asset-byline"  ><a href="https://www.galvnews.com/users/profile/Kelsey%20Walling">KELSEY WALLING/The Daily News</a></span>
                </li>
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        
    <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_daf3013a-2287-51ae-a0e6-b75c59307c56.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" rel="noopener" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/free/image_daf3013a-2287-51ae-a0e6-b75c59307c56.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":daf3013a-2287-51ae-a0e6-b75c59307c56}'  rel="nofollow">
            
                <span class=" tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_daf3013a-2287-51ae-a0e6-b75c59307c56.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share&text=Dynamo%20vs.%20Galaxy&via=GalvNews" class="tw" target="_blank" rel="noopener" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/free/image_daf3013a-2287-51ae-a0e6-b75c59307c56.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":daf3013a-2287-51ae-a0e6-b75c59307c56}'  rel="nofollow">
                <span class=" tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BThe%20Daily%20News%5D%20Dynamo%20vs.%20Galaxy&body=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_daf3013a-2287-51ae-a0e6-b75c59307c56.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":daf3013a-2287-51ae-a0e6-b75c59307c56}'  rel="nofollow">
                <span class=" tnt-stack" >
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/free/image_daf3013a-2287-51ae-a0e6-b75c59307c56.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":daf3013a-2287-51ae-a0e6-b75c59307c56}'  rel="nofollow">
                    <span class=" tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link">
        <a class="save-list-daf3013a-2287-51ae-a0e6-b75c59307c56-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="daf3013a-2287-51ae-a0e6-b75c59307c56" >
            <span class=" tnt-stack">
                
                <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
            </span>
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul>
    <form method="post" data-uuid="daf3013a-2287-51ae-a0e6-b75c59307c56" class="save-list-daf3013a-2287-51ae-a0e6-b75c59307c56-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="daf3013a-2287-51ae-a0e6-b75c59307c56" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
                        <div class="item photo-c7d65e17-93c4-55eb-978e-955b6f1b46e5 hidden-print">
                            <div class="item-container">
        
                                <div data-track-object='{"title":"Galaxy’s star power not enough, as Dynamo win wild one","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html","uuid":"69b920e1-b858-59ca-a526-e462074bc51e","app":"editorial","metric":""}'  data-count="4"  class="photo-container layout-vertical">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                        
                                        
        
        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                    alt="Dynamo vs. Galaxy"
                    class="img-responsive owl-lazy"
                    width="1134"
                    height="1827"
                    data-src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/c/7d/c7d65e17-93c4-55eb-978e-955b6f1b46e5/5aee75d090557.image.jpg" />
                                        
                                        
                                </div>
        <div class="caption-container">
                
                    <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal" data-target=".caption-inner-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal">
                        <i class="fas tnt-minus-circle"></i>
                    </span>
                
            <div class="caption-inner-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal collapse in"><div class="caption-text"><p>Houston Dynamo defender Adolfo Maschado gets past L.A. Galaxy forward Zlatan Ibrahimovic and runs toward the goal during a game at BBVA Compass Stadium in Houston on Saturday, May 5, 2018. The Dynamo will be playing at Vancouver on Friday.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span id="author-656b01ae-7620-11e7-9848-5cb9017bff18-asset-c7d65e17-93c4-55eb-978e-955b6f1b46e5" class="asset-byline"  ><a href="https://www.galvnews.com/users/profile/Kelsey%20Walling">KELSEY WALLING/The Daily News</a></span>
                </li>
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        
    <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_c7d65e17-93c4-55eb-978e-955b6f1b46e5.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" rel="noopener" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/free/image_c7d65e17-93c4-55eb-978e-955b6f1b46e5.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":c7d65e17-93c4-55eb-978e-955b6f1b46e5}'  rel="nofollow">
            
                <span class=" tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_c7d65e17-93c4-55eb-978e-955b6f1b46e5.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share&text=Dynamo%20vs.%20Galaxy&via=GalvNews" class="tw" target="_blank" rel="noopener" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/free/image_c7d65e17-93c4-55eb-978e-955b6f1b46e5.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":c7d65e17-93c4-55eb-978e-955b6f1b46e5}'  rel="nofollow">
                <span class=" tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BThe%20Daily%20News%5D%20Dynamo%20vs.%20Galaxy&body=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_c7d65e17-93c4-55eb-978e-955b6f1b46e5.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":c7d65e17-93c4-55eb-978e-955b6f1b46e5}'  rel="nofollow">
                <span class=" tnt-stack" >
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/free/image_c7d65e17-93c4-55eb-978e-955b6f1b46e5.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":c7d65e17-93c4-55eb-978e-955b6f1b46e5}'  rel="nofollow">
                    <span class=" tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link">
        <a class="save-list-c7d65e17-93c4-55eb-978e-955b6f1b46e5-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="c7d65e17-93c4-55eb-978e-955b6f1b46e5" >
            <span class=" tnt-stack">
                
                <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
            </span>
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul>
    <form method="post" data-uuid="c7d65e17-93c4-55eb-978e-955b6f1b46e5" class="save-list-c7d65e17-93c4-55eb-978e-955b6f1b46e5-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="c7d65e17-93c4-55eb-978e-955b6f1b46e5" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
                        <div class="item photo-2f21eb22-2996-5835-803d-d157f81dee7a hidden-print">
                            <div class="item-container">
        
                                <div data-track-object='{"title":"Galaxy’s star power not enough, as Dynamo win wild one","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html","uuid":"69b920e1-b858-59ca-a526-e462074bc51e","app":"editorial","metric":""}'  data-count="5"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                        
                                        
        
        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                    alt="Dynamo vs. Galaxy"
                    class="img-responsive owl-lazy"
                    width="1747"
                    height="1185"
                    data-src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/2/f2/2f21eb22-2996-5835-803d-d157f81dee7a/5aee75d04e6cd.image.jpg?resize=1200%2C814" />
                                        
                                        
                                </div>
        <div class="caption-container">
                
                    <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal" data-target=".caption-inner-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal">
                        <i class="fas tnt-minus-circle"></i>
                    </span>
                
            <div class="caption-inner-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal collapse in"><div class="caption-text"><p>Fans react to a call on the Houston Dynamo during a match against L.A. Galaxy at BBVA Compass Stadium in Houston on Saturday, May 5, 2018.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span id="author-656b01ae-7620-11e7-9848-5cb9017bff18-asset-2f21eb22-2996-5835-803d-d157f81dee7a" class="asset-byline"  ><a href="https://www.galvnews.com/users/profile/Kelsey%20Walling">KELSEY WALLING/The Daily News</a></span>
                </li>
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        
    <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_2f21eb22-2996-5835-803d-d157f81dee7a.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" rel="noopener" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/free/image_2f21eb22-2996-5835-803d-d157f81dee7a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":2f21eb22-2996-5835-803d-d157f81dee7a}'  rel="nofollow">
            
                <span class=" tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_2f21eb22-2996-5835-803d-d157f81dee7a.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share&text=Dynamo%20vs.%20Galaxy&via=GalvNews" class="tw" target="_blank" rel="noopener" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/free/image_2f21eb22-2996-5835-803d-d157f81dee7a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":2f21eb22-2996-5835-803d-d157f81dee7a}'  rel="nofollow">
                <span class=" tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BThe%20Daily%20News%5D%20Dynamo%20vs.%20Galaxy&body=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_2f21eb22-2996-5835-803d-d157f81dee7a.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":2f21eb22-2996-5835-803d-d157f81dee7a}'  rel="nofollow">
                <span class=" tnt-stack" >
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/free/image_2f21eb22-2996-5835-803d-d157f81dee7a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":2f21eb22-2996-5835-803d-d157f81dee7a}'  rel="nofollow">
                    <span class=" tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link">
        <a class="save-list-2f21eb22-2996-5835-803d-d157f81dee7a-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="2f21eb22-2996-5835-803d-d157f81dee7a" >
            <span class=" tnt-stack">
                
                <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
            </span>
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul>
    <form method="post" data-uuid="2f21eb22-2996-5835-803d-d157f81dee7a" class="save-list-2f21eb22-2996-5835-803d-d157f81dee7a-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="2f21eb22-2996-5835-803d-d157f81dee7a" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
                        <div class="item photo-31184c56-b714-5c4c-abf1-e0aff716073a hidden-print">
                            <div class="item-container">
        
                                <div data-track-object='{"title":"Galaxy’s star power not enough, as Dynamo win wild one","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html","uuid":"69b920e1-b858-59ca-a526-e462074bc51e","app":"editorial","metric":""}'  data-count="6"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                        
                                        
        
        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                    alt="Dynamo vs. Galaxy"
                    class="img-responsive owl-lazy"
                    width="1667"
                    height="1243"
                    data-src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/3/11/31184c56-b714-5c4c-abf1-e0aff716073a/5aee75cfe392a.image.jpg?resize=1200%2C895" />
                                        
                                        
                                </div>
        <div class="caption-container">
                
                    <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal" data-target=".caption-inner-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal">
                        <i class="fas tnt-minus-circle"></i>
                    </span>
                
            <div class="caption-inner-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal collapse in"><div class="caption-text"><p>Houston Dynamo midfielder Tomas Martinez looks for a teammate to pass to as L.A. Galaxy midfielder Perry Kitchen runs toward him during a game at BBVA Compass Stadium in Houston on Saturday, May 5, 2018.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span id="author-656b01ae-7620-11e7-9848-5cb9017bff18-asset-31184c56-b714-5c4c-abf1-e0aff716073a" class="asset-byline"  ><a href="https://www.galvnews.com/users/profile/Kelsey%20Walling">KELSEY WALLING/The Daily News</a></span>
                </li>
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        
    <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_31184c56-b714-5c4c-abf1-e0aff716073a.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" rel="noopener" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/free/image_31184c56-b714-5c4c-abf1-e0aff716073a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":31184c56-b714-5c4c-abf1-e0aff716073a}'  rel="nofollow">
            
                <span class=" tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_31184c56-b714-5c4c-abf1-e0aff716073a.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share&text=Dynamo%20vs.%20Galaxy&via=GalvNews" class="tw" target="_blank" rel="noopener" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/free/image_31184c56-b714-5c4c-abf1-e0aff716073a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":31184c56-b714-5c4c-abf1-e0aff716073a}'  rel="nofollow">
                <span class=" tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BThe%20Daily%20News%5D%20Dynamo%20vs.%20Galaxy&body=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_31184c56-b714-5c4c-abf1-e0aff716073a.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":31184c56-b714-5c4c-abf1-e0aff716073a}'  rel="nofollow">
                <span class=" tnt-stack" >
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/free/image_31184c56-b714-5c4c-abf1-e0aff716073a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":31184c56-b714-5c4c-abf1-e0aff716073a}'  rel="nofollow">
                    <span class=" tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link">
        <a class="save-list-31184c56-b714-5c4c-abf1-e0aff716073a-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="31184c56-b714-5c4c-abf1-e0aff716073a" >
            <span class=" tnt-stack">
                
                <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
            </span>
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul>
    <form method="post" data-uuid="31184c56-b714-5c4c-abf1-e0aff716073a" class="save-list-31184c56-b714-5c4c-abf1-e0aff716073a-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="31184c56-b714-5c4c-abf1-e0aff716073a" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
                        <div class="item photo-eca24153-711d-5846-a507-fe3654d48454 hidden-print">
                            <div class="item-container">
        
                                <div data-track-object='{"title":"Galaxy’s star power not enough, as Dynamo win wild one","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html","uuid":"69b920e1-b858-59ca-a526-e462074bc51e","app":"editorial","metric":""}'  data-count="7"  class="photo-container layout-vertical">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                        
                                        
        
        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                    alt="Dynamo vs. Galaxy"
                    class="img-responsive owl-lazy"
                    width="1154"
                    height="1796"
                    data-src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/e/ca/eca24153-711d-5846-a507-fe3654d48454/5aee75ceefa35.image.jpg" />
                                        
                                        
                                </div>
        <div class="caption-container">
                
                    <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal" data-target=".caption-inner-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal">
                        <i class="fas tnt-minus-circle"></i>
                    </span>
                
            <div class="caption-inner-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal collapse in"><div class="caption-text"><p>Houston Dynamo midfielder Tomas Martinez attempts to get the ball away from L.A. Galaxy midfielder Jonathon dos Santos during a match at BBVA Compass Stadium in Houston on Saturday, May 5, 2018.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span id="author-656b01ae-7620-11e7-9848-5cb9017bff18-asset-eca24153-711d-5846-a507-fe3654d48454" class="asset-byline"  ><a href="https://www.galvnews.com/users/profile/Kelsey%20Walling">KELSEY WALLING/The Daily News</a></span>
                </li>
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        
    <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_eca24153-711d-5846-a507-fe3654d48454.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" rel="noopener" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/free/image_eca24153-711d-5846-a507-fe3654d48454.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":eca24153-711d-5846-a507-fe3654d48454}'  rel="nofollow">
            
                <span class=" tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_eca24153-711d-5846-a507-fe3654d48454.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share&text=Dynamo%20vs.%20Galaxy&via=GalvNews" class="tw" target="_blank" rel="noopener" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/free/image_eca24153-711d-5846-a507-fe3654d48454.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":eca24153-711d-5846-a507-fe3654d48454}'  rel="nofollow">
                <span class=" tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BThe%20Daily%20News%5D%20Dynamo%20vs.%20Galaxy&body=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Fimage_eca24153-711d-5846-a507-fe3654d48454.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":eca24153-711d-5846-a507-fe3654d48454}'  rel="nofollow">
                <span class=" tnt-stack" >
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/free/image_eca24153-711d-5846-a507-fe3654d48454.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":eca24153-711d-5846-a507-fe3654d48454}'  rel="nofollow">
                    <span class=" tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link">
        <a class="save-list-eca24153-711d-5846-a507-fe3654d48454-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="eca24153-711d-5846-a507-fe3654d48454" >
            <span class=" tnt-stack">
                
                <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
            </span>
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul>
    <form method="post" data-uuid="eca24153-711d-5846-a507-fe3654d48454" class="save-list-eca24153-711d-5846-a507-fe3654d48454-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="eca24153-711d-5846-a507-fe3654d48454" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
            </div>
        </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </div>
    </div><article itemscope itemtype="http://schema.org/Article" id="asset-69b920e1-b858-59ca-a526-e462074bc51e" class="asset article-default"  data-url="http://www.galvnews.com/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html"><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/b/f6/bf6be6ea-1be6-5bca-aeb5-38803fb8362c/5aee75d018b51.image.jpg?resize=825%2C630">
            <meta itemprop="width" content="825">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="galvnews.com">
    </div>
    <link itemprop="mainEntityOfPage" href="http://www.galvnews.com/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html" />
    <div class="asset-paging-container hidden-print">
            <div id="asset-paging-69b920e1-b858-59ca-a526-e462074bc51e" class="asset-paging">
                <div id="paging-prev-69b920e1-b858-59ca-a526-e462074bc51e" class="paging-link prev offset"></div>
                <div id="paging-next-69b920e1-b858-59ca-a526-e462074bc51e" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <script>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</script><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Galaxy’s star power not enough, as Dynamo win wild one
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span id="author-popup-3ff36c2c-d457-11e3-891c-001a4bcf6878-asset-69b920e1-b858-59ca-a526-e462074bc51e" class="asset-byline" rel="popover" itemprop="author"><a href="https://www.galvnews.com/users/profile/James%20LaCombe">By JAMES LACOMBE
The Daily News
</a></span>
                
                    <div id="author-popup-3ff36c2c-d457-11e3-891c-001a4bcf6878-asset-69b920e1-b858-59ca-a526-e462074bc51e-content" class="hide">
                        <article class="clearfix card author popup-content card-author-3ff36c2c-d457-11e3-891c-001a4bcf6878">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.galvnews.com/users/profile/James%20LaCombe" rel="author">James LaCombe</a>
                                </h4>
    
        <ul class="list-inline social-links hidden-print">
	        <li>
	            <a href="mailto:james.lacombe@galvnews.com" title="Email">
	                <span class=" tnt-stack">
	                    
	                    <i class="fas tnt-envelope tnt-stack-1x"></i>
	                </span>
	            </a>
	        </li>
	</ul></div>
                        </div>
                    </div>
                </div>
            </article>
                    </div>
                    <script>
                        $('#author-popup-3ff36c2c-d457-11e3-891c-001a4bcf6878-asset-69b920e1-b858-59ca-a526-e462074bc51e').popover({
                            content: $('#author-popup-3ff36c2c-d457-11e3-891c-001a4bcf6878-asset-69b920e1-b858-59ca-a526-e462074bc51e-content').html(),
                            html:true,
                            trigger:'hover',
                            placement:'top',
                            delay:{ show:100, hide:200 }
                        });
                    </script>
                </li>
        
        
            <li>
        <time datetime="2018-05-05T22:10:00-05:00" class="asset-date text-muted">3 hrs ago</time></li>
        
        
            <li class="hidden-print"><a href="/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html#comments" class="cm" title="0 comments"><span class="fas tnt-comments"></span> <span class="count">0</span></a>
</li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2018-05-05T22:10:00-05:00">
    <meta itemprop="datePublished" content="2018-05-05T22:10:00-05:00">
    <meta itemprop="dateModified" content="2018-05-05T22:10:00-05:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove>
                
    <ul class="social-share-links hidden-print list-unstyled stacked icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Farticle_69b920e1-b858-59ca-a526-e462074bc51e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" rel="noopener" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":69b920e1-b858-59ca-a526-e462074bc51e}'  rel="nofollow">
            
                <span class=" tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Farticle_69b920e1-b858-59ca-a526-e462074bc51e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share&text=Galaxy%E2%80%99s%20star%20power%20not%20enough%2C%20as%20Dynamo%20win%20wild%20one&via=GalvNews" class="tw" target="_blank" rel="noopener" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":69b920e1-b858-59ca-a526-e462074bc51e}'  rel="nofollow">
                <span class=" tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BThe%20Daily%20News%5D%20Galaxy%E2%80%99s%20star%20power%20not%20enough%2C%20as%20Dynamo%20win%20wild%20one&body=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Farticle_69b920e1-b858-59ca-a526-e462074bc51e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":69b920e1-b858-59ca-a526-e462074bc51e}'  rel="nofollow">
                <span class=" tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul>
    <form method="post" data-uuid="69b920e1-b858-59ca-a526-e462074bc51e" class="save-list-69b920e1-b858-59ca-a526-e462074bc51e-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="69b920e1-b858-59ca-a526-e462074bc51e" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

            </div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div id="asset-photo-carousel"><div id="carousel-69b920e1-b858-59ca-a526-e462074bc51e" class="card photo-carousel    subscriber-hide">
            <div class="photo-carousel-control-container">
                    <a class="photo-carousel-control left noselect hidden-print"><span class="control-left fas tnt-chevron-left"></span></a>
                    <a class="photo-carousel-control right noselect hidden-print"><span class="control-left fas tnt-chevron-right"></span></a>
            </div>
            <div id="gallery-items-69b920e1-b858-59ca-a526-e462074bc51e" class="carousel-inner">
                        <div class="item photo-bf6be6ea-1be6-5bca-aeb5-38803fb8362c">
                            <div class="item-container">
        
                                <div data-track-object='{"title":"Galaxy’s star power not enough, as Dynamo win wild one","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html","uuid":"69b920e1-b858-59ca-a526-e462074bc51e","app":"editorial","metric":""}'  data-count="1"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                            <a href="#1" data-photo-target=".photo-bf6be6ea-1be6-5bca-aeb5-38803fb8362c" data-instance="#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal" data-target="#photo-carousel-69b920e1-b858-59ca-a526-e462074bc51e" class="hover-expand">
                                                <span class="expand">
                                                    <span class="fas tnt-expand"></span>
                                                </span>
                                        
                                        
                                        
        <div itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
            <meta itemprop="width" content="1647">
            <meta itemprop="height" content="1258">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/b/f6/bf6be6ea-1be6-5bca-aeb5-38803fb8362c/5aee75d018b51.image.jpg?resize=1200%2C917">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/b/f6/bf6be6ea-1be6-5bca-aeb5-38803fb8362c/5aee75d018b51.image.jpg?resize=1200%2C917">
        
        
        
                <img
                    src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/b/f6/bf6be6ea-1be6-5bca-aeb5-38803fb8362c/5aee75d018b51.image.jpg?resize=1200%2C917"
                    
                    alt="Dynamo vs. Galaxy"
                    class="img-responsive owl-first-image owl-lazy"
                    width="1647"
                    height="1258"
                    data-src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/b/f6/bf6be6ea-1be6-5bca-aeb5-38803fb8362c/5aee75d018b51.image.jpg?resize=1200%2C917" />
            </div>
                                        
                                        </a><div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-69b920e1-b858-59ca-a526-e462074bc51e collapse in"><div class="caption-text"><p>Houston Dynamo forward Alberth Elis gets kneed in the chest by L.A. Galaxy goalkeeper David Bingham during a game at BBVA Compass Stadium in Houston on Saturday, May 5, 2018. The Dynamo won the game 3-2.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span id="author-656b01ae-7620-11e7-9848-5cb9017bff18-asset-bf6be6ea-1be6-5bca-aeb5-38803fb8362c" class="asset-byline"  ><a href="https://www.galvnews.com/users/profile/Kelsey%20Walling">KELSEY WALLING/The Daily News</a></span>
                </li>
                                
                            
                            
                            
                        </ul>
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
                        <div class="item photo-109bbc0c-5dfb-5a32-8e65-be768988fdc6 hidden-print">
                            <div class="item-container">
        
                                <div data-track-object='{"title":"Galaxy’s star power not enough, as Dynamo win wild one","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html","uuid":"69b920e1-b858-59ca-a526-e462074bc51e","app":"editorial","metric":""}'  data-count="2"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                            <a href="#2" data-photo-target=".photo-109bbc0c-5dfb-5a32-8e65-be768988fdc6" data-instance="#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal" data-target="#photo-carousel-69b920e1-b858-59ca-a526-e462074bc51e" class="hover-expand">
                                                <span class="expand">
                                                    <span class="fas tnt-expand"></span>
                                                </span>
                                        
                                        
                                        
        <div itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
            <meta itemprop="width" content="1641">
            <meta itemprop="height" content="1263">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/1/09/109bbc0c-5dfb-5a32-8e65-be768988fdc6/5aee75cf72891.image.jpg?resize=1200%2C924">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/1/09/109bbc0c-5dfb-5a32-8e65-be768988fdc6/5aee75cf72891.image.jpg?resize=1200%2C924">
        
        
        
                <img
                    src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/1/09/109bbc0c-5dfb-5a32-8e65-be768988fdc6/5aee75cf72891.image.jpg?resize=1200%2C924"
                    
                    alt="Dynamo vs. Galaxy"
                    class="img-responsive owl-first-image owl-lazy"
                    width="1641"
                    height="1263"
                    data-src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/1/09/109bbc0c-5dfb-5a32-8e65-be768988fdc6/5aee75cf72891.image.jpg?resize=1200%2C924" />
            </div>
                                        
                                        </a><div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-69b920e1-b858-59ca-a526-e462074bc51e collapse in"><div class="caption-text"><p>Dynamo midfielder Osdcar Boniek Garcia gets the ball away from L.A. Galaxy midfielder Jonathon dos Santos <span class="print_trim">during a game at BBVA Compass Stadium in Houston</span> on Saturday<span class="print_trim">, May 5, 2018</span>.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span id="author-656b01ae-7620-11e7-9848-5cb9017bff18-asset-109bbc0c-5dfb-5a32-8e65-be768988fdc6" class="asset-byline"  ><a href="https://www.galvnews.com/users/profile/Kelsey%20Walling">KELSEY WALLING/The Daily News
<!--p:PC Photo Credit--></a></span>
                </li>
                                
                            
                            
                            
                        </ul>
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
                        <div class="item photo-daf3013a-2287-51ae-a0e6-b75c59307c56 hidden-print">
                            <div class="item-container">
        
                                <div data-track-object='{"title":"Galaxy’s star power not enough, as Dynamo win wild one","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html","uuid":"69b920e1-b858-59ca-a526-e462074bc51e","app":"editorial","metric":""}'  data-count="3"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                            <a href="#3" data-photo-target=".photo-daf3013a-2287-51ae-a0e6-b75c59307c56" data-instance="#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal" data-target="#photo-carousel-69b920e1-b858-59ca-a526-e462074bc51e" class="hover-expand">
                                                <span class="expand">
                                                    <span class="fas tnt-expand"></span>
                                                </span>
                                        
                                        
                                        
        <div itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
            <meta itemprop="width" content="1635">
            <meta itemprop="height" content="1268">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/d/af/daf3013a-2287-51ae-a0e6-b75c59307c56/5aee75d0b940c.image.jpg?resize=1200%2C931">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/d/af/daf3013a-2287-51ae-a0e6-b75c59307c56/5aee75d0b940c.image.jpg?resize=1200%2C931">
        
        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                    alt="Dynamo vs. Galaxy"
                    class="img-responsive owl-lazy"
                    width="1635"
                    height="1268"
                    data-src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/d/af/daf3013a-2287-51ae-a0e6-b75c59307c56/5aee75d0b940c.image.jpg?resize=1200%2C931" />
            </div>
                                        
                                        </a><div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-69b920e1-b858-59ca-a526-e462074bc51e collapse in"><div class="caption-text"><p>Houston Dynamo defender DaMarcus Beasley kicks for an attempted goal as L.A. Galaxy forward Chris Pontius attempts to block him during a game at BBVA Compass Stadium in Houston on Saturday, May 5, 2018.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span id="author-656b01ae-7620-11e7-9848-5cb9017bff18-asset-daf3013a-2287-51ae-a0e6-b75c59307c56" class="asset-byline"  ><a href="https://www.galvnews.com/users/profile/Kelsey%20Walling">KELSEY WALLING/The Daily News</a></span>
                </li>
                                
                            
                            
                            
                        </ul>
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
                        <div class="item photo-c7d65e17-93c4-55eb-978e-955b6f1b46e5 hidden-print">
                            <div class="item-container">
        
                                <div data-track-object='{"title":"Galaxy’s star power not enough, as Dynamo win wild one","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html","uuid":"69b920e1-b858-59ca-a526-e462074bc51e","app":"editorial","metric":""}'  data-count="4"  class="photo-container layout-vertical">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                            <a href="#4" data-photo-target=".photo-c7d65e17-93c4-55eb-978e-955b6f1b46e5" data-instance="#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal" data-target="#photo-carousel-69b920e1-b858-59ca-a526-e462074bc51e" class="hover-expand">
                                                <span class="expand">
                                                    <span class="fas tnt-expand"></span>
                                                </span>
                                        
                                        
                                        
        <div itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
            <meta itemprop="width" content="1134">
            <meta itemprop="height" content="1827">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/c/7d/c7d65e17-93c4-55eb-978e-955b6f1b46e5/5aee75d090557.image.jpg">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/c/7d/c7d65e17-93c4-55eb-978e-955b6f1b46e5/5aee75d090557.image.jpg">
        
        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                    alt="Dynamo vs. Galaxy"
                    class="img-responsive owl-lazy"
                    width="1134"
                    height="1827"
                    data-src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/c/7d/c7d65e17-93c4-55eb-978e-955b6f1b46e5/5aee75d090557.image.jpg" />
            </div>
                                        
                                        </a><div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-69b920e1-b858-59ca-a526-e462074bc51e collapse in"><div class="caption-text"><p>Houston Dynamo defender Adolfo Maschado gets past L.A. Galaxy forward Zlatan Ibrahimovic and runs toward the goal during a game at BBVA Compass Stadium in Houston on Saturday, May 5, 2018. The Dynamo will be playing at Vancouver on Friday.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span id="author-656b01ae-7620-11e7-9848-5cb9017bff18-asset-c7d65e17-93c4-55eb-978e-955b6f1b46e5" class="asset-byline"  ><a href="https://www.galvnews.com/users/profile/Kelsey%20Walling">KELSEY WALLING/The Daily News</a></span>
                </li>
                                
                            
                            
                            
                        </ul>
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
                        <div class="item photo-2f21eb22-2996-5835-803d-d157f81dee7a hidden-print">
                            <div class="item-container">
        
                                <div data-track-object='{"title":"Galaxy’s star power not enough, as Dynamo win wild one","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html","uuid":"69b920e1-b858-59ca-a526-e462074bc51e","app":"editorial","metric":""}'  data-count="5"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                            <a href="#5" data-photo-target=".photo-2f21eb22-2996-5835-803d-d157f81dee7a" data-instance="#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal" data-target="#photo-carousel-69b920e1-b858-59ca-a526-e462074bc51e" class="hover-expand">
                                                <span class="expand">
                                                    <span class="fas tnt-expand"></span>
                                                </span>
                                        
                                        
                                        
        <div itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
            <meta itemprop="width" content="1747">
            <meta itemprop="height" content="1185">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/2/f2/2f21eb22-2996-5835-803d-d157f81dee7a/5aee75d04e6cd.image.jpg?resize=1200%2C814">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/2/f2/2f21eb22-2996-5835-803d-d157f81dee7a/5aee75d04e6cd.image.jpg?resize=1200%2C814">
        
        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                    alt="Dynamo vs. Galaxy"
                    class="img-responsive owl-lazy"
                    width="1747"
                    height="1185"
                    data-src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/2/f2/2f21eb22-2996-5835-803d-d157f81dee7a/5aee75d04e6cd.image.jpg?resize=1200%2C814" />
            </div>
                                        
                                        </a><div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-69b920e1-b858-59ca-a526-e462074bc51e collapse in"><div class="caption-text"><p>Fans react to a call on the Houston Dynamo during a match against L.A. Galaxy at BBVA Compass Stadium in Houston on Saturday, May 5, 2018.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span id="author-656b01ae-7620-11e7-9848-5cb9017bff18-asset-2f21eb22-2996-5835-803d-d157f81dee7a" class="asset-byline"  ><a href="https://www.galvnews.com/users/profile/Kelsey%20Walling">KELSEY WALLING/The Daily News</a></span>
                </li>
                                
                            
                            
                            
                        </ul>
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
                        <div class="item photo-31184c56-b714-5c4c-abf1-e0aff716073a hidden-print">
                            <div class="item-container">
        
                                <div data-track-object='{"title":"Galaxy’s star power not enough, as Dynamo win wild one","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html","uuid":"69b920e1-b858-59ca-a526-e462074bc51e","app":"editorial","metric":""}'  data-count="6"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                            <a href="#6" data-photo-target=".photo-31184c56-b714-5c4c-abf1-e0aff716073a" data-instance="#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal" data-target="#photo-carousel-69b920e1-b858-59ca-a526-e462074bc51e" class="hover-expand">
                                                <span class="expand">
                                                    <span class="fas tnt-expand"></span>
                                                </span>
                                        
                                        
                                        
        <div itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
            <meta itemprop="width" content="1667">
            <meta itemprop="height" content="1243">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/3/11/31184c56-b714-5c4c-abf1-e0aff716073a/5aee75cfe392a.image.jpg?resize=1200%2C895">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/3/11/31184c56-b714-5c4c-abf1-e0aff716073a/5aee75cfe392a.image.jpg?resize=1200%2C895">
        
        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                    alt="Dynamo vs. Galaxy"
                    class="img-responsive owl-lazy"
                    width="1667"
                    height="1243"
                    data-src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/3/11/31184c56-b714-5c4c-abf1-e0aff716073a/5aee75cfe392a.image.jpg?resize=1200%2C895" />
            </div>
                                        
                                        </a><div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-69b920e1-b858-59ca-a526-e462074bc51e collapse in"><div class="caption-text"><p>Houston Dynamo midfielder Tomas Martinez looks for a teammate to pass to as L.A. Galaxy midfielder Perry Kitchen runs toward him during a game at BBVA Compass Stadium in Houston on Saturday, May 5, 2018.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span id="author-656b01ae-7620-11e7-9848-5cb9017bff18-asset-31184c56-b714-5c4c-abf1-e0aff716073a" class="asset-byline"  ><a href="https://www.galvnews.com/users/profile/Kelsey%20Walling">KELSEY WALLING/The Daily News</a></span>
                </li>
                                
                            
                            
                            
                        </ul>
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
                        <div class="item photo-eca24153-711d-5846-a507-fe3654d48454 hidden-print">
                            <div class="item-container">
        
                                <div data-track-object='{"title":"Galaxy’s star power not enough, as Dynamo win wild one","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html","uuid":"69b920e1-b858-59ca-a526-e462074bc51e","app":"editorial","metric":""}'  data-count="7"  class="photo-container layout-vertical">
                                            <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                        
                                        
                                            <a href="#7" data-photo-target=".photo-eca24153-711d-5846-a507-fe3654d48454" data-instance="#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal" data-target="#photo-carousel-69b920e1-b858-59ca-a526-e462074bc51e" class="hover-expand">
                                                <span class="expand">
                                                    <span class="fas tnt-expand"></span>
                                                </span>
                                        
                                        
                                        
        <div itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
            <meta itemprop="width" content="1154">
            <meta itemprop="height" content="1796">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/e/ca/eca24153-711d-5846-a507-fe3654d48454/5aee75ceefa35.image.jpg">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/e/ca/eca24153-711d-5846-a507-fe3654d48454/5aee75ceefa35.image.jpg">
        
        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                    alt="Dynamo vs. Galaxy"
                    class="img-responsive owl-lazy"
                    width="1154"
                    height="1796"
                    data-src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/content/tncms/assets/v3/editorial/e/ca/eca24153-711d-5846-a507-fe3654d48454/5aee75ceefa35.image.jpg" />
            </div>
                                        
                                        </a><div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-69b920e1-b858-59ca-a526-e462074bc51e collapse in"><div class="caption-text"><p>Houston Dynamo midfielder Tomas Martinez attempts to get the ball away from L.A. Galaxy midfielder Jonathon dos Santos during a match at BBVA Compass Stadium in Houston on Saturday, May 5, 2018.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span id="author-656b01ae-7620-11e7-9848-5cb9017bff18-asset-eca24153-711d-5846-a507-fe3654d48454" class="asset-byline"  ><a href="https://www.galvnews.com/users/profile/Kelsey%20Walling">KELSEY WALLING/The Daily News</a></span>
                </li>
                                
                            
                            
                            
                        </ul>
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
            </div>
        </div></div>
            

            

            
            
            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="69b920e1-b858-59ca-a526-e462074bc51e">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove>
    <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Farticle_69b920e1-b858-59ca-a526-e462074bc51e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" rel="noopener" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":69b920e1-b858-59ca-a526-e462074bc51e}'  rel="nofollow">
            
                <span class=" tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Farticle_69b920e1-b858-59ca-a526-e462074bc51e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share&text=Galaxy%E2%80%99s%20star%20power%20not%20enough%2C%20as%20Dynamo%20win%20wild%20one&via=GalvNews" class="tw" target="_blank" rel="noopener" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":69b920e1-b858-59ca-a526-e462074bc51e}'  rel="nofollow">
                <span class=" tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BThe%20Daily%20News%5D%20Galaxy%E2%80%99s%20star%20power%20not%20enough%2C%20as%20Dynamo%20win%20wild%20one&body=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Farticle_69b920e1-b858-59ca-a526-e462074bc51e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":69b920e1-b858-59ca-a526-e462074bc51e}'  rel="nofollow">
                <span class=" tnt-stack" >
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":69b920e1-b858-59ca-a526-e462074bc51e}'  rel="nofollow">
                    <span class=" tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link">
        <a class="save-list-69b920e1-b858-59ca-a526-e462074bc51e-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="69b920e1-b858-59ca-a526-e462074bc51e" >
            <span class=" tnt-stack">
                
                <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
            </span>
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul>
    <form method="post" data-uuid="69b920e1-b858-59ca-a526-e462074bc51e" class="save-list-69b920e1-b858-59ca-a526-e462074bc51e-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="69b920e1-b858-59ca-a526-e462074bc51e" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                            
                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div itemprop="articleBody" class="asset-content  subscriber-premium">
                                
                                
                                <p>HOUSTON</p><p>While the Los Angeles Galaxy had the match’s leading man, it was the Houston Dynamo’s supporting cast that got the win, 3-2, on Saturday night at BBVA Compass Stadium.</p><p>“It’s a good reward for a group of men who have fought a lot today,” Dynamo head coach Wilmer Cabrera said. “They won with a good mentality on the field. The mentality was good against a team that is very talented.”</p><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p>Houston scored the match-winner in the 89th minute of this wild thriller thanks to a pair of late-match substitutions off the bench.</p><p>Oscar Boniek Garcia sent a nice pass into the penalty box, but a shot attempt deflected off the top crossbar. However, Memo Rodriguez was there for the rebound, which he headed into the goal for the 3-2 advantage.</p><p>“We know that we’re going to continue to fight for 90 minutes trying to win the game, we’re never going to give up, and today, we were rewarded with that third goal and the three points,” Cabrera said.</p><p>The Dynamo were on the scoreboard quickly to start the match, as a Romell Quioto free kick from a few yards outside the box in the third minute found an open Alejandro Fuenmayor, who put it away for a 1-0 lead.</p><p>The Galaxy knotted the score, 1-1, in the 39th minute on a counterattack, with two of the team’s biggest names combining forces.</p><p>International superstar and recent MLS signee Zlatan Ibrahimovic’s shot on goal was stopped by Houston goalkeeper Joe Willis, but Mexican national team standout Giovani dos Santos cleaned up the deflection and put the ball in the back of the net.</p><p>In the 48th minute, the Dynamo re-took the lead off a free kick from Quioto from the edge of the left side of the box. Quioto’s shot into the penalty area caught a deflection that sent it into the goal for a 2-1 lead.</p><p>A late equalizer saw L.A. threaten to secure the draw, as a fast-breaking dos Santos placed a beauty of a pass deep in the penalty area to Ola Kamara, who flicked the ball into the goal to even the score, 2-2, in the 85th minute.</p><p><span class="print_trim">In the 23rd minute, Quito fired off a shot from outside of the penalty area, but that sailed a few feet high. In a virtually identical free kick scenario that saw the first Dynamo goal scored, Quioto took a crack at a goal, but his bending shot skimmed just over the left upper 90 in the 35th minute. Alberth Elis sent a dangerous cross into the box in the 43rd minute that fell just off-target.</span></p><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><p><span class="print_trim">Off a free kick in the 61st minute, Darwin Ceren gathered up the ball after a couple deflections and rocketed a shot on goal, but Galaxy keeper David Bingham was able to make the stop.</span></p><p><span class="print_trim">The star attraction Ibrahimovic had another shot attempt in the 65th minute, but he shanked it to the left of the goal, much to the Swede’s disgust. Cabrera said there was no game plan made specifically for Ibrahimovic.</span></p><p><span class="print_trim">“We needed to be us, we needed to be Houston Dynamo, the way we are,” Cabrera said. “We cannot change, because if we change, we’re going to make mistakes. We’re going to try to invent something that we don’t know, and if we do that, we’re going to look even worse.”</span></p><p><span class="print_trim">In the 68th minute, Elis’ shot on goal was saved by Bingham. On a fast break in the 81st minute, Ceren’s cross in the box was sent too early to find what would have been a wide-open Elis. A dangerous Dynamo cross in the 88th minute was deftly defended by L.A.</span></p><p><span class="print_trim">The Dynamo more than doubled the number of shots on target in the match against the Galaxy (9-4), despite L.A. controlling possession by a significant margin (54.8 percent to 45.2 percent).</span></p><p>Up next for the Dynamo (3-3-2) will be a long road trip for a 9:30 p.m. match Friday at Vancouver.</p><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>
                            
                           

                            
                                <div class="asset-tagline text-muted"><p>James LaCombe: 409-683-5242, <a href="mailto:james.lacombe@galvnews.com">james.lacombe@galvnews.com</a> or on Twitter @JamesAtGalvNews<!--p:BCT Tagline--></p></div>
                            
                            
                            
        

                            
                            
                                <div class="share-container content-below" data-subscription-required-remove>
    <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Farticle_69b920e1-b858-59ca-a526-e462074bc51e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" rel="noopener" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":69b920e1-b858-59ca-a526-e462074bc51e}'  rel="nofollow">
            
                <span class=" tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Farticle_69b920e1-b858-59ca-a526-e462074bc51e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share&text=Galaxy%E2%80%99s%20star%20power%20not%20enough%2C%20as%20Dynamo%20win%20wild%20one&via=GalvNews" class="tw" target="_blank" rel="noopener" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":69b920e1-b858-59ca-a526-e462074bc51e}'  rel="nofollow">
                <span class=" tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BThe%20Daily%20News%5D%20Galaxy%E2%80%99s%20star%20power%20not%20enough%2C%20as%20Dynamo%20win%20wild%20one&body=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Farticle_69b920e1-b858-59ca-a526-e462074bc51e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":69b920e1-b858-59ca-a526-e462074bc51e}'  rel="nofollow">
                <span class=" tnt-stack" >
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":69b920e1-b858-59ca-a526-e462074bc51e}'  rel="nofollow">
                    <span class=" tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link">
        <a class="save-list-69b920e1-b858-59ca-a526-e462074bc51e-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="69b920e1-b858-59ca-a526-e462074bc51e" >
            <span class=" tnt-stack">
                
                <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
            </span>
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul>
    <form method="post" data-uuid="69b920e1-b858-59ca-a526-e462074bc51e" class="save-list-69b920e1-b858-59ca-a526-e462074bc51e-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="69b920e1-b858-59ca-a526-e462074bc51e" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    
                        
                            <div class="asset-author">
                                <article class="clearfix card author  card-author-3ff36c2c-d457-11e3-891c-001a4bcf6878">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.galvnews.com/users/profile/James%20LaCombe" rel="author">James LaCombe</a>
                                </h4>
    
        <ul class="list-inline social-links hidden-print">
	        <li>
	            <a href="mailto:james.lacombe@galvnews.com" title="Email">
	                <span class=" tnt-stack">
	                    
	                    <i class="fas tnt-envelope tnt-stack-1x"></i>
	                </span>
	            </a>
	        </li>
	</ul><div class="followed-notify-link hidden-print"><div class="followed-notify-container">
        <div class="logged-in">
            <button class="btn btn-success btn-sm" data-toggle="modal" data-target="#followed-notification-modal-3ff36c2c-d457-11e3-891c-001a4bcf6878-user">
                <i class="fas tnt-star"></i> Follow James LaCombe
            </button>
            <div id="followed-notification-modal-3ff36c2c-d457-11e3-891c-001a4bcf6878-user" class="modal fade">
                <div class="modal-dialog">
                    <div class="modal-content">
                        <div class="modal-header">
                            <button type="button" class="close" data-dismiss="modal">
                                <i class="fas tnt-times-circle"></i>
                                <span class="sr-only">Close</span>
                            </button>
                            <h4 class="modal-title">Get email notifications on James LaCombe daily!</h4>
                        </div>
                        <div class="modal-body">
                            <div class="alert alert-success fade in" style="display:none;">
                                Your notification has been saved.
                            </div>
                            <div class="alert alert-danger fade in" style="display:none;">
                                There was a problem saving your notification.
                            </div>
                            
                                <p class="notification-description">
                                    
                                        Whenever James LaCombe posts new content, you'll get an email delivered to your inbox with a link.
                                    
                                </p>
                            
                            <p>Email notifications are only sent once a day, and only if there are new matching items.</p>
                            <form class="follow-notify-form" action="/search/savedsearch/save/?a=3ff36c2c-d457-11e3-891c-001a4bcf6878&amp;s=start_time&amp;sd=desc" method="post">
                                <input class="input-notification-name" type="hidden" name="title" value="James LaCombe notification">
                                <div class="row">
                                    <div class="col-sm-6">
                                        <button class="btn btn-success btn-block follow-btn" >
                                            <i class="fas tnt-spinner tnt-pulse" style="display:none;"></i> Save
                                        </button>
                                    </div>
                                    <div class="col-sm-6">
                                        <a class="btn btn-default btn-block" href="https://www.galvnews.com/users/admin/savedsearch/">Manage followed notifications</a>
                                    </div>
                                </div>
                            </form>
                            <script>
                                jQuery(document).ready(function($){
                                    $('.follow-notify-form').submit(function(e) {
                                        e.preventDefault();
                                        var $followBtn = $('.follow-btn');
                                        var sAction = $(this).attr('action') + '&title=' + $('.input-notification-name').val();
                                        
                                            $followBtn.find('.tnt-svg').show();
                                        
                                        $followBtn.prop('disabled', true);

                                        function submit_finished($alert){
                                            setTimeout(function(){
                                                
                                                    $followBtn.find('.tnt-svg').hide();
                                                
                                                $alert.show().delay(2500).fadeOut(400);
                                            },2000);
                                        }

                                        $.ajax({
                                            type: 'POST',
                                            url: sAction,
                                            data: $(this).serialize(),
                                            success: function(oData){
                                                
                                                    // Track follow event
                                                    __tnt.trackEvent({
                                                        'network': 'Site',
                                                        'socialAction': 'Follow',
                                                        'url': 'https://www.galvnews.com/users/profile/3ff36c2c-d457-11e3-891c-001a4bcf6878'
                                                    });
                                                
                                                submit_finished( $('#followed-notification-modal-3ff36c2c-d457-11e3-891c-001a4bcf6878-user .alert-success') );
                                            },
                                            error: function(oData){
                                                submit_finished( $('#followed-notification-modal-3ff36c2c-d457-11e3-891c-001a4bcf6878-user .alert-danger') );
                                            }
                                        });
                                    });
                                });
                            </script>
                        </div>
                    </div>
                </div>
            </div>
        </div>
        <div class="not-logged-in"><button class="btn btn-success btn-sm" data-toggle="modal" data-target="#followed-notification-modal-3ff36c2c-d457-11e3-891c-001a4bcf6878">
                <i class="fas tnt-star"></i> Follow James LaCombe
            </button>
            <div id="followed-notification-modal-3ff36c2c-d457-11e3-891c-001a4bcf6878" class="modal fade">
                <div class="modal-dialog modal-sm">
                    <div class="modal-content">
                        <div class="modal-header">
                            <button type="button" class="close" data-dismiss="modal">
                                <i class="fas tnt-times-circle"></i>
                                <span class="sr-only">Close</span>
                            </button>
                            <h4 class="modal-title">Followed notifications</h4>
                        </div>
                        <div class="modal-body">
                            <div class="padding-bottom">
                                <h4>Please log in to use this feature</h4>
                                <a class="btn btn-block btn-primary" href="https://www.galvnews.com/users/login/?referer_url=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Farticle_69b920e1-b858-59ca-a526-e462074bc51e.html%3Fmodalid%3Dfollowed-notification-modal-3ff36c2c-d457-11e3-891c-001a4bcf6878" rel="nofollow">Log In</a>
                            </div>
                            <div class="user-signup">
                                <strong>Don't have an account?</strong> <a href="https://www.galvnews.com/users/signup/?referer_url=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Farticle_69b920e1-b858-59ca-a526-e462074bc51e.html" rel="nofollow">Sign Up Today</a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </div>
        
    </div></div></div>
                        </div>
                    </div>
                </div>
            </article>
                            </div>
                        
                    

                    

                    
               
                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div>

                    

                    
                    
                    
                    
                    <div class="asset-comments hidden-print">
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Post a comment<span class="not-logged-in"> as </span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="69b920e1-b858-59ca-a526-e462074bc51e" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Posting">Post comment</button>
                    </div>
                </div>

                <div class="template success" style="display:none">
                <!-- <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your comment has been submitted.</p>
    </div>

    <div class="comment-body media-body">

        <div class="avatar img-responsive"><i class="fas tnt-user tnt-fw"></i></div>
        <img class="avatar img-responsive" src="" alt="" />

        <div class="comment-heading  media-heading">
            <strong class="username"></strong>
        </div>
                
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
-->
                </div>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/sports/free/article_69b920e1-b858-59ca-a526-e462074bc51e.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <div class="template success" style="display:none">
                <!-- <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div> -->
                </div>

                <div class="template error" style="display:none">
                <!-- <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div> -->
                </div>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch this discussion.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this discussion.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="69b920e1-b858-59ca-a526-e462074bc51e" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone contributes to the discussion
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this discussion will be disabled.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div class="comments-container">
        <section id="comments" class=" subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fas tnt-comments"></span> (0) comments 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom asc realnames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Welcome to the discussion.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://www.galvnews.com/users/login/?referer_url=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Farticle_69b920e1-b858-59ca-a526-e462074bc51e.html">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules"><strong>Keep it Clean.</strong> Please avoid obscene, vulgar, lewd,
racist or sexually-oriented language.<br>
<strong>PLEASE TURN OFF YOUR CAPS LOCK.</strong><br>
<strong>Don&#39;t Threaten.</strong> Threats of harming another
person will not be tolerated.<br>
<strong>Be Truthful.</strong> Don&#39;t knowingly lie about anyone
or anything.<br>
<strong>Be Nice.</strong> No racism, sexism or any sort of -ism
that is degrading to another person.<br>
<strong>Be Proactive.</strong> Use the &#39;Report&#39; link on
each comment to let us know of abusive posts.<br>
<strong>Share with Us.</strong> We&#39;d love to hear eyewitness
accounts, the history behind an article.
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Post a comment</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch this discussion.</span>
                                    <span class="unsubscribe">Stop watching this discussion.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div><div class="subscriber-hide"><div class="meter message">
        <div class="wall panel panel-default">
            <div class="panel-body">
                <h4 class="meter-heading media-heading">
                    Thank you for Reading!

                </h4>
                <p>Please <span class="not-logged-in">log in, or sign up for a new account and</span> purchase a subscription to read or post comments.</p>

                <div class="col-xs-12">
                    <div class="row ">
                        <div class="pull-right">
                            
    <a class="btn btn-default not-logged-in" href="https://www.galvnews.com/users/login/?referer_url=http%3A%2F%2Fwww.galvnews.com%2Fsports%2Ffree%2Farticle_69b920e1-b858-59ca-a526-e462074bc51e.html">Log In</a>
                            <a class="btn btn-default logged-in" href="https://www.galvnews.com/users/admin/service/purchase/?referer_url=http%253A%252F%252Fwww.galvnews.com%252Fsports%252Ffree%252Farticle_69b920e1-b858-59ca-a526-e462074bc51e.html">Purchase a Subscription
</a>
                        </div>
                    </div>
                    </div>
            </div>
        </div>
        </div>
    
    
</div></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-531916" class="tncms-block hidden-xs">
        <div id="blox-ad-position-block-rectangle-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-rectangle-top","slot":"1","fold":"above","width":"300","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/galvnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-508899" class="tncms-block"><section id="block-508899" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-508899 ">
        <div class="block-title-inner">
            <h4>
                
                Most Popular
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-508899" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
        
        
        
            <li >
                <a href="#collections-508899" data-toggle="tab"><i class="far tnt-copy" title="Collections"></i><span class="tab-text"> Collections</span></a>
            </li>
        
        
            <li >
                <a href="#commented-508899" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-508899" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-decimal "><li><a href="/news/free/article_32834fa1-2f34-5352-b92f-ae2d550afe8a.html">Investigators name man shot dead in SWAT raid</a></li><li><a href="/news/free/article_6281e454-d372-56b9-aa35-867b960f3e96.html">Haney indicted on two manslaughter charges</a></li><li><a href="/news/free/article_f34f3920-24d8-59d0-b5db-46e723580c79.html">Man charged in Texas City killing</a></li><li><a href="/news/free/article_ff707c68-8265-5f10-9ec1-18ea3567a4dc.html">Woman charged with assault after wild ride</a></li><li><a href="/news/free/article_18b70114-462d-5de8-a41f-ea8cb25ceb51.html">Police ID those involved in Texas City shooting</a></li><li><a href="/business/buzz/article_28a55f72-96f0-5e45-9b7f-739b196ea9eb.html">Developer divulges Palmer Plaza plan; landlord locks out Tilted Kilt</a></li><li><a href="/news/free/article_27678992-b549-52f5-9b69-63ee9610a38d.html">2018 Local Elections, Final Election Night Results</a></li><li><a href="/news/article_fc9cb878-fb61-5552-bdb0-60cef3111c4a.html">Deadly raid netted pot, two felony possession charges</a></li><li><a href="/news/free/article_5b6c7d34-9142-5bb9-bf5d-95fe6156928c.html">Two charged after Galveston drug raids</a></li><li><a href="/news/article_0eeec213-307d-559f-8496-0c44f0d43fac.html">Woman gets 10 years probation for killing husband</a></li></ul></div>
        
        
        
        
        
            <div id="collections-508899" class="tab-pane tab-pane-collections fade in ">
                <h4 class="tab-content-heading">Collections</h4><ul class="tab-content-list bullet-decimal "><li><a href="/blogs/in_focus/collection_9eece6aa-faa1-5f12-8ff0-26568e48f6b8.html">Photos: 2018 Galveston Island Beach Revue</a></li><li><a href="/blogs/in_focus/collection_1cb29d81-dde3-5fae-b0af-c0b102fe3d6b.html">Photos: Yankees 4, Astros 0</a></li><li><a href="/blogs/in_focus/collection_bc13549f-ea2e-5b23-941a-3f2241a08ba9.html">Photos: Astros 8, Athletics 4</a></li><li><a href="/blogs/in_focus/collection_50758caf-153f-516d-91e3-82f4779dfc3b.html">Photos: 2018 UTMB School of Nursing Commencement Ceremony</a></li><li><a href="/blogs/in_focus/collection_0d97717e-c05e-508e-ab06-95abff38b0ea.html">Photos: Final weekend of the Galveston County Fair & Rodeo</a></li><li><a href="/blogs/in_focus/collection_34d276a0-8411-53e4-a50b-961da2967ea1.html">Photos: Saturday at the Galveston County Fair & Rodeo</a></li><li><a href="/blogs/in_focus/collection_3840c165-4a12-5f29-9f41-ef42fc681777.html">Photos: TCISD Foundation for the Future's annual Youthfest & Duck Derby</a></li><li><a href="/blogs/in_focus/collection_874fe305-6fb6-5a16-9391-6eef81e0b6e3.html">Photos: Galveston County Fair and Rodeo</a></li><li><a href="/news/collection_1158beab-f760-5857-8b47-4e6e42fa1b16.html">Texas City celebrates its 44th Cinco de Mayo festival</a></li><li><a href="/blogs/in_focus/collection_ddee60a9-f068-503b-8759-a44eff97e45a.html">Photos: Angels 2, Astros 0</a></li></ul></div>
        
        
            <div id="commented-508899" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><ul class="tab-content-list bullet-decimal "><li><a href="/opinion/letters_to_editor/article_3c54e9cd-5fe7-5d16-969a-7a3e997a1d84.html">Where is the outrage over Trump's untruths?</a> (69)</li><li><a href="/news/article_28cc8526-97b3-594b-8b79-b3cc6fbbb7aa.html">Early voting, impeachment talk and a peculiar parsonage</a> (44)</li><li><a href="/news/article_a8b2dcac-ae60-5e2c-b45c-8cc9e9690813.html">ACLU monitoring county's magistrate hearings</a> (27)</li><li><a href="/news/article_d60e5cda-0d59-5255-acbf-5a83da75597b.html">County hires law firms to defend ACLU lawsuit</a> (26)</li><li><a href="/news/article_8ed17974-170e-5a7c-ac4d-35077717ff65.html">Converting houses into duplexes could soon be banned</a> (23)</li><li><a href="/news/article_22908c03-a4ac-5ba1-aaf4-d17c3e91a747.html">Texas City students participate in nationwide 'walkout'</a> (21)</li><li><a href="/news/article_265c551b-bf1f-5576-b0ab-3c9f5a0a57cd.html">Texas City HS students plan walkout Friday</a> (21)</li><li><a href="/opinion/editorials/article_71e46355-3cb4-5558-9fb7-3f5c02bd64a1.html">Plenty of blame to go around in public housing debacle</a> (21)</li><li><a href="/news_ap/business/article_8e7b55da-1e3a-5a98-9b0e-f61b0eda0707.html">Survey: US businesses added 204,000 jobs in April</a> (20)</li><li><a href="/opinion/guest_columns/article_8a4aa4f0-d17f-5775-ae67-dd8e059a4820.html">Truth, buzzwords and the District 3 race</a> (18)</li></ul></div>
        
    </div>
</div></section></div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-531917" class="tncms-block hidden-xs">
        <div id="blox-ad-position-block-rectangle-middle1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-rectangle-middle","slot":"1","fold":"span","width":"300","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/galvnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-531918" class="tncms-block hidden-xs">
        <div id="blox-ad-position-block-rectangle-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-rectangle-bottom","slot":"1","fold":"below","width":"300","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/galvnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>



        <div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-508841" class="tncms-block hidden-xs">
        <div id="blox-ad-position-block-leaderboard-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom","slot":"1","fold":"below","width":"728","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/galvnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-508842" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-leaderboard-bottom-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom-mobile","slot":"1","fold":"below","width":"320","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/galvnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4">
        <div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-508967" class="tncms-block"><section id="block-508967" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-508967 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link"  href="/news/" >
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link"  href="/sports/" >
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link"  href="/opinion/" >
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link"  href="/blogs/" >
                    <span class="nav-label">Blogs</span>
                </a></li><li>
                <a class="nav-link"  href="http://www.coastmonthly.com"  target="_blank" rel="noopener">
                    <span class="nav-label">Coast</span>
                </a></li><li>
                <a class="nav-link"  href="/weather/" >
                    <span class="nav-label">Weather</span>
                </a></li></ul></div>
    </div>
    <div id="footer-col-two" class="col-md-4 col-sm-4">
        <div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-508890" class="tncms-block"><section id="block-508890" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-508890 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link"  href="/site/services/" >
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link"  href="/classifieds/" >
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link"  href="/classifieds/housing/" >
                    <span class="nav-label">Homes</span>
                </a></li><li>
                <a class="nav-link"  href="/classifieds/vehicle/" >
                    <span class="nav-label">Autos</span>
                </a></li><li>
                <a class="nav-link"  href="/classifieds/job/" >
                    <span class="nav-label">Jobs</span>
                </a></li><li>
                <a class="nav-link"  href="/site/shopping_front.html" >
                    <span class="nav-label">Shopping</span>
                </a></li></ul></div>
    </div>
    <div id="footer-col-three" class="col-md-4 col-sm-4">
        <div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-508968" class="tncms-block"><section id="block-508968" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-508968 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div></section></div><div id="tncms-block-508969" class="tncms-block"><section id="block-508969" class="block emphasis-h4   " ><address>
    <strong>The Daily News</strong><br>
    8522 Teichman Road<br>
    Galveston, TX 77554
    <br>
    
        <strong>Phone:</strong> 409-683-5200<br>
        <strong>Email:</strong> <a href="mailto:website.feedback@galvnews.com">website.feedback@galvnews.com</a><br>
    
</address></section></div><div id="tncms-block-508977" class="tncms-block padding-bottom"><div class="follow-links-508977 default">
    
    <section id="block-508977" class="block emphasis-h4   " ><ul class="list-inline">
        
            <li>
                <a href=" https://www.facebook.com/GalvNews" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/GalvNews" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
            <li>
                <a href="https://www.instagram.com/galvnews/" title="Instagram" target="_blank" rel="noopener" class="btn btn-md btn-link is">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "http://schema.org",
  "@type" : "Organization",
  "url" : "http://www.galvnews.com",
  "sameAs" : [" https://www.facebook.com/GalvNews","https://twitter.com/GalvNews","https://www.instagram.com/galvnews/"] 
}
</script>
<div class="clearfix"></div>
    <script>
        jQuery(document).ready(function(){
            $('.follow-links-508977 li a').tooltip({
                placement:'bottom'
            });
        });
    </script>
</div></div>
        <div id="tncms-region-nav-footer-col-three-nav" class="tncms-region-nav"><ul id="footer-col-three-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link"  href="/site/forms/subscription_services/deliveryissue/" >
                    <span class="nav-label">Customer Service</span>
                </a></li><li>
                <a class="nav-link"  href="/site/forms/online_services/how_to_advertise/" >
                    <span class="nav-label">Advertising</span>
                </a></li><li>
                <a class="nav-link"  href="/site/forms/online_services/submit_news/" >
                    <span class="nav-label">Newsroom</span>
                </a></li><li>
                <a class="nav-link"  href="/site/forms/online_services/contact_support/" >
                    <span class="nav-label">Contact Support</span>
                </a></li></ul></div>
    </div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-508894" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-508894"><div class="col-xs-12"><small>© 2017 Galveston Newspapers, Inc.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    <div id="sticky-anchor"><div id="tncms-region-page_sticky_anchor" class="tncms-region hidden-print collapse in"></div></div>
    <!-- / site-container close -->
    </div>
    
    
    <script>
$(function(){
    var compatible = true;
    var status = "";
    if(typeof(__tnt.advertisements)=="undefined"){
        compatible = false;
        status = "FAIL: object 0 undefined"
    }
    if(typeof(__tnt.ads)=="undefined"){
        compatible = false;
        status = "FAIL: object 1 undefined"
    }
    
    if(!compatible){
        __tnt.log(status);
        
        if(window.ga){
            __tnt.trackEvent({'category':'tnt-adblock','action':'adblock','label':'adblock detected','value':'1'}); 
        
        }
    }
});
</script>

    <!-- Google Analytics:Begin -->
        <script type="text/javascript">
            window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;    
            ga('create', 'UA-11548769-1', 'galvnews.com', {'allowLinker': true});
            
            ga('set', 'forceSSL', true);
            ga('require', 'linkid', 'linkid.js');
            ga('require', 'displayfeatures');
            ga('send', 'pageview');
        </script>
        <script>
            __tnt.googleEvent = function(obj) {
                ga('send', 'event', obj.category, obj.action, obj.label, obj.value);
            }
            __tnt.googleSocial = function(obj) {
                ga('send', 'social', obj.network, obj.socialAction, obj.url);
            }
            __tnt.googlePageView = function(obj) {
                var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                ga('send', 'pageview', {
                    'page': sURL,
                    'title': obj.title
                });
            }
        </script>
        <!-- Google:End -->
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }
        });
    </script>
<script>
        __tnt.trackEvent = function(obj) {
            if( jQuery.type(obj) === 'object' ){
                
                    
                        
                        if(obj.category && obj.action){
                            __tnt.googleEvent(obj);
                        } else if(obj.network && obj.socialAction){
                            __tnt.googleSocial(obj);
                        } else if(obj.url){
                            __tnt.googlePageView(obj);
                        }
                    if(typeof TNCMS.Tracking != 'undefined' && obj.metric){
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
                
            }
        }
        
        if(__tnt.trackEventLater.length > 0){
            jQuery(__tnt.trackEventLater).each(function(){
                __tnt.trackEvent($(this));
            });
        }
        jQuery('body').on(__tnt.client.clickEvent, '[data-track]', function(){
            var trkObj = jQuery(this).data('track');
            __tnt.trackEvent(trkObj);
        });
        jQuery('body').on(__tnt.client.clickEvent, '[data-tncms-track-event]', function(){
            var trkObj = jQuery(this).data('tncms-track-event');
            __tnt.trackEvent(trkObj);
        });
        jQuery('body').on(__tnt.client.clickEvent, '[data-tncms-track-dmp]', function(){
            var dmpData = jQuery(this).data('tncms-track-dmp');
            });
    </script>
    
<script>/*<![CDATA[*/ $(function() {
        var avatar_508979 = $('#user-controls-508979 .tn-user-avatar');
        if(__tnt.user.loggedIn && __tnt.user.avatar){
            avatar_508979.append('<img src="' + __tnt.user.avatar + '" class="user-icon">');
        } else{
            avatar_508979.append('<i class="fas tnt-user tnt-fw user-icon"></i>');
        }
    }); /*]]>*/</script>
<script>/*<![CDATA[*/ $(function() {
        var avatar_508978 = $('#user-controls-508978 .tn-user-avatar');
        if(__tnt.user.loggedIn && __tnt.user.avatar){
            avatar_508978.append('<img src="' + __tnt.user.avatar + '" class="user-icon">');
        } else{
            avatar_508978.append('<i class="fas tnt-user tnt-fw user-icon"></i>');
        }
    }); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.747126c4ce78b9d2c827e747d5ee6510.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/owl.carousel.min.a23229b8d8ee5f1919a5a9663946b1f7.js"></script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
                var gallery_ad_69b920e1_b858_59ca_a526_e462074bc51e_photo_modal = false;
                var gallery_changed_69b920e1_b858_59ca_a526_e462074bc51e_photo_modal = false;
                $('#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal').owlCarousel({
                    items: 1,
                    autoHeight: true,
                    lazyLoad: true,
                    loop: false,
                    navRewind: true,
                    responsiveRefreshRate: 500,
                    
                    
                    dots : false,
                    onTranslated:function(){
                        
                        
                        
                            __tnt.trackEvent($('#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal .photo-container').eq(this._current).data('track-object'));
                        

                        
                        

                        

                    }
                });
                
                var owl = $('#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal');
                owl.on('changed.owl.carousel', function(event) {if( !$('#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal .photo-container').eq(event.item.index).hasClass('engagement-stage') ){
                        setTimeout(function(){
                            $("#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal .owl-stage-outer").height( $('#carousel-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal .owl-item.active').height() );
                        }, 300);
                    }
                 
                 
                        

                        
                            var currItem = $('#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal .photo-container').eq(event.item.index).data('count');
                            if(currItem){
                                $('#carousel-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal .current-count').html(currItem);
                            }
                            $('.modal.in, #carousel-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal .item').removeClass('hover');
                        
                        
                });
                
                var photo_carousel_69b920e1_b858_59ca_a526_e462074bc51e_photo_modal = $('#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal').data('owlCarousel');
                $('#carousel-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal .photo-carousel-control.left').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_69b920e1_b858_59ca_a526_e462074bc51e_photo_modal.prev();
                });
                $('#carousel-69b920e1-b858-59ca-a526-e462074bc51e-photo-modal .photo-carousel-control.right').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_69b920e1_b858_59ca_a526_e462074bc51e_photo_modal.next();
                });
            }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                // open photo modal
                jQuery(document).ready(function($){
                    $('[data-photo-target]').on('click', function(e){
                        e.preventDefault();
                        var item_target = $(this).data('target');
                        // get item index
                        var item_index = $(item_target +' '+$(this).data('photo-target')).parent().index();
                        // get current instance of carousel
                        var carousel_instance = $(this).data('instance');
                        var carousel_instance_data = $(carousel_instance).data('owlCarousel');
                        // fix non explict widths at viewports less than 900.
                        if(carousel_instance_data.width() < 320 & carousel_instance_data.viewport() < 900){
                            carousel_instance_data.onThrottledResize();
                        }
                        // load item from index
                        carousel_instance_data.to(item_index, 100, true);
                        // open modal
                        $(item_target).modal({'show':true});
                        __tnt.trackEvent({'category':'tnt-lightbox','action':'carousel-open', 'label':'article', 'value':'1'});
                        return false;
                    });
                    $('.photo-carousel-caption-toggle').on(__tnt.client.clickEvent, function(e){
                        var item_instance = $(this).data('instance');
                        
                            $(item_instance +' .photo-carousel-caption-toggle').find('[data-fa-i2svg]').attr('data-icon', $(item_instance +' .photo-carousel-caption-toggle').find('[data-fa-i2svg]').attr('data-icon') == 'minus-circle' ? 'plus-circle' : 'minus-circle');
                        
                    });
                }); /*]]>*/</script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
                var gallery_ad_69b920e1_b858_59ca_a526_e462074bc51e = false;
                var gallery_changed_69b920e1_b858_59ca_a526_e462074bc51e = false;
                $('#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e').owlCarousel({
                    items: 1,
                    autoHeight: true,
                    lazyLoad: true,
                    loop: false,
                    navRewind: true,
                    responsiveRefreshRate: 500,
                    
                    
                    dots : false,
                    onTranslated:function(){
                        
                        
                        
                            __tnt.trackEvent($('#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e .photo-container').eq(this._current).data('track-object'));
                        

                        
                        

                        

                    }
                });
                
                var owl = $('#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e');
                owl.on('changed.owl.carousel', function(event) {if( !$('#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e .photo-container').eq(event.item.index).hasClass('engagement-stage') ){
                        setTimeout(function(){
                            $("#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e .owl-stage-outer").height( $('#carousel-69b920e1-b858-59ca-a526-e462074bc51e .owl-item.active').height() );
                        }, 300);
                    }
                 
                 
                        try {
            
            var bOnlyDFP = false, bIsOAS = false;
            if( typeof gptAdSlots != 'undefined' ){
                        googletag.cmd.push(function(){
                            googletag.pubads().clear();
                            googletag.pubads().refresh();
                        });}
                /* reloadByIds will return false/0 if the ad slot called for hasn't actually been loaded to the page. */
                if( typeof __tnt.ads.oas != 'undefined' ) bIsOAS = !!__tnt.ads.oas.reloadByIds();
            
                if( !bOnlyDFP && !bIsOAS && typeof TNCMS.AdManager != 'undefined' ){
                        TNCMS.AdManager.refresh({region: ''});}
            } catch(e) {
            __tnt.log(e);
        }

                        
                        
                });
                
                var photo_carousel_69b920e1_b858_59ca_a526_e462074bc51e = $('#gallery-items-69b920e1-b858-59ca-a526-e462074bc51e').data('owlCarousel');
                $('#carousel-69b920e1-b858-59ca-a526-e462074bc51e .photo-carousel-control.left').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_69b920e1_b858_59ca_a526_e462074bc51e.prev();
                });
                $('#carousel-69b920e1-b858-59ca-a526-e462074bc51e .photo-carousel-control.right').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_69b920e1_b858_59ca_a526_e462074bc51e.next();
                });
            }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
        document.addEventListener("DOMContentLoaded", function() {
            __tnt.metering.comments.access(document.querySelector(".comments-container, .comments-expand, #comments-collapsible-toggle"), document.querySelector(".asset-comments .meter.message"));
        });
     /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sticky-kit.1bb05400ffcc4ea686561f22e5585bbd.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/galvnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.regions.49f8577e340523d389649716f1ac77e8.js"></script>
<script>/*<![CDATA[*/ (function($){
                $(window).load(function(){
                    __tnt.regions.stickySide.init($('#sticky-right-rail'), $('#sticky-right-rail-spacer'), 'siderail');
                });
            })(jQuery); /*]]>*/</script>
<script>/*<![CDATA[*/ __tnt.regions.stickyAnchor.init(); /*]]>*/</script></body>
</html>